Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233565 - [RHEL-4] Turkey DST Update
Summary: [RHEL-4] Turkey DST Update
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: tzdata
Version: 4.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Petr Machata
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 233566
TreeView+ depends on / blocked
 
Reported: 2007-03-23 09:21 UTC by Ozgur Yuksel
Modified: 2015-05-05 01:33 UTC (History)
1 user (show)

Fixed In Version: RHEA-2007-0128
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-23 22:15:43 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2007:0128 normal SHIPPED_LIVE tzdata enhancement update 2007-03-23 22:15:40 UTC

Description Ozgur Yuksel 2007-03-23 09:21:55 UTC
Description of problem:

   DST switch times are changed to 1am UTC in Turkey starting with 2007 for EU 
conformity. But with RHEL 4 Update 4:

  # zdump -v Turkey | grep 2007
  Turkey  Sat Mar 24 22:59:59 2007 UTC = Sun Mar 25 00:59:59 2007 EET isdst=0
gmtoff=7200
  Turkey  Sat Mar 24 23:00:00 2007 UTC = Sun Mar 25 02:00:00 2007 EEST isdst=1
gmtoff=10800
  Turkey  Sat Oct 27 22:59:59 2007 UTC = Sun Oct 28 01:59:59 2007 EEST isdst=1
gmtoff=10800
  Turkey  Sat Oct 27 23:00:00 2007 UTC = Sun Oct 28 01:00:00 2007 EET isdst=0
gmtoff=7200

Version-Release number of selected component (if applicable):
   tzdata-2007c-1.el4

How reproducible: 
   Consistently

Steps to Reproduce:
1.    zdump -v Turkey | grep 2007

Actual results:
  Turkey  Sat Mar 24 22:59:59 2007 UTC = Sun Mar 25 00:59:59 2007 EET isdst=0
gmtoff=7200
  Turkey  Sat Mar 24 23:00:00 2007 UTC = Sun Mar 25 02:00:00 2007 EEST isdst=1
gmtoff=10800
  Turkey  Sat Oct 27 22:59:59 2007 UTC = Sun Oct 28 01:59:59 2007 EEST isdst=1
gmtoff=10800
  Turkey  Sat Oct 27 23:00:00 2007 UTC = Sun Oct 28 01:00:00 2007 EET isdst=0
gmtoff=7200


Expected results:
  Turkey  Sun Mar 25 00:59:59 2007 UTC = Sun Mar 25 02:59:59 2007 EET isdst=0
gmtoff=7200
  Turkey  Sun Mar 25 01:00:00 2007 UTC = Sun Mar 25 04:00:00 2007 EEST isdst=1
gmtoff=10800
  Turkey  Sun Oct 28 00:59:59 2007 UTC = Sun Oct 28 03:59:59 2007 EEST isdst=1
gmtoff=10800
  Turkey  Sun Oct 28 01:00:00 2007 UTC = Sun Oct 28 03:00:00 2007 EET isdst=0
gmtoff=7200

Additional info:

   With tzdata-2006m-2.fc6 on RHEL5, the problem does not exist.

Comment 1 Petr Machata 2007-03-23 09:29:47 UTC
Right, 2007d contains the necessary updates.  2006m is only correct because
there was a bug in assuming that Turkey used and will use EU rules, which they
are only using this year.

In any case, we'll need to get this out ASYNC for all RHELs.

Comment 7 Red Hat Bugzilla 2007-03-23 22:15:43 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2007-0128.html



Note You need to log in before you can comment on or make changes to this bug.