Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233553 - undefined symbol error for gnome_vfs_mime_get_default_component when starting up evolution
Summary: undefined symbol error for gnome_vfs_mime_get_default_component when starting...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-23 05:48 UTC by Jonathan Kamens
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-23 21:10:12 UTC


Attachments (Terms of Use)

Description Jonathan Kamens 2007-03-23 05:48:31 UTC
jik2:~!1018$ evolution&
[2] 11644
jik2:~!1019$ CalDAV Eplugin starting up ...

(evolution:11644): e-utils-WARNING **: can't load plugin
'/usr/lib/evolution/2.10/components/libevolution-mail.so: undefined symbol:
gnome_vfs_mime_get_default_component'

jik2:~!1031$  rpm -q evolution gnome-vfs2
evolution-2.10.0-2.fc7
gnome-vfs2-2.18.0.1-1.fc7

Comment 1 Matthew Barnes 2007-03-23 12:48:50 UTC
What version of libbonobo do you have?  Perhaps this is a missing dependency.

Comment 2 Jonathan Kamens 2007-03-23 18:38:47 UTC
That could have been the problem.  I've updated to the current libbonobo. 
Unfortunately, I wasn't able to reproduce the problem reliably before I did
that, so I don't know how to verify for sure that the problem is fixed.  You can
close the ticket with CURRENTVERSION if you'd like, and I'll reopen it if I
encounter the issue again.


Comment 3 Matthew Barnes 2007-03-23 21:10:12 UTC
Sounds good.  I'll close it as WORKSFORME.  That particular symbol is in the
libbonobo package (despite its name), so remember to mention the libbonbo
version you're using if you wind up reopening this.


Note You need to log in before you can comment on or make changes to this bug.