Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233540 - utrace: wait does not report immediately after PTRACE_ATTACH of process already in job control stop
Summary: utrace: wait does not report immediately after PTRACE_ATTACH of process alre...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Roland McGrath
QA Contact: Martin Jenner
URL:
Whiteboard:
: 289411 (view as bug list)
Depends On: 232837
Blocks: 233853
TreeView+ depends on / blocked
 
Reported: 2007-03-23 00:49 UTC by Roland McGrath
Modified: 2007-11-30 22:07 UTC (History)
4 users (show)

Fixed In Version: RHBA-2007-0959
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-07 19:45:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0959 normal SHIPPED_LIVE Updated kernel packages for Red Hat Enterprise Linux 5 Update 1 2007-11-08 00:47:37 UTC

Description Roland McGrath 2007-03-23 00:49:44 UTC
+++ This bug was initially created as a clone of Bug #232837 +++

The frysk test suite now has a good regression test for this issue, which I've
fixed in the Fedora kernel.  The behavior is a regression from RHEL4 and all
prior kernels.

Comment 1 RHEL Product and Program Management 2007-03-23 01:06:08 UTC
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.

Comment 4 RHEL Product and Program Management 2007-06-20 12:31:34 UTC
This request was evaluated by Red Hat Kernel Team for inclusion in a Red
Hat Enterprise Linux maintenance release, and has moved to bugzilla 
status POST.

Comment 5 Don Zickus 2007-07-19 20:06:35 UTC
in kernel-2.6.18-30.el5

Comment 7 Mike Gahagan 2007-08-28 19:47:33 UTC
Which testcase should be used to verify this bug? This is the only difference
I'm seeing in running the test suite that comes with frysk. Is the stopkills
test case the one I should be looking at for this bug?

[root@test183 tests]# diff out.2.6.18-*
18c18
< PASS: frysk4330/stopkills
---
> FAIL: frysk4330/stopkills
[root@test183 tests]# echo diff out.2.6.18-*
diff out.2.6.18-43.el5 out.2.6.18-8.el5

the failure mode according to strace is the ptrace(PTRACE_DETACH,...) call is
failing with a -ESRCH (No such process), but I'm not sure if that applies here.


Comment 8 Mike Gahagan 2007-08-28 20:30:13 UTC
nevermind... looks like the testcase I mentioned in comment 7 is for bz235545
which is also fixed. :). I found the testcase in Bug #232837 and I can confirm
it is fixed with the -43 kernel.


Comment 9 Jan Kratochvil 2007-09-23 22:48:48 UTC
*** Bug 289411 has been marked as a duplicate of this bug. ***

Comment 11 errata-xmlrpc 2007-11-07 19:45:10 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0959.html



Note You need to log in before you can comment on or make changes to this bug.