Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233537 - Lack of x86 kernel-PAE Support for >16GB in RHEL5
Summary: Lack of x86 kernel-PAE Support for >16GB in RHEL5
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.0
Hardware: i686
OS: Linux
high
high
Target Milestone: ---
: ---
Assignee: Peter Martuccelli
QA Contact: Martin Jenner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-22 23:06 UTC by Larry Troan
Modified: 2016-04-18 09:46 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-08-13 19:52:36 UTC


Attachments (Terms of Use)
sos -- Kernel-PAE.tar.bz2 (deleted)
2007-03-22 23:09 UTC, Larry Troan
no flags Details

Description Larry Troan 2007-03-22 23:06:20 UTC
Description of problem:
RHEL 4 supports up to 64GB using the hugemem kernel. 

RHEL 5 does not ship the hugemem kernel and officially restricts support to
systems of 16GB or less. However, kernel-PAE will install and run systems up to
64GB with no warning message that this is an invalid consiguration.
Engineering's position is that customers wanting to run larger systems should
migrate to x86_64 architecture.

Though there are not a large number of x86 systems, the ones that do exist
typically are from large customers and we are inhibiting them from migrating to
RHEL5. Many can't easily migrate their applications to run on 64 bit or they
don't own the proprietary application software.

The intent of this bug is to resolve the migration roadblock that customers 
running x86 16-64GB systems will experience if they can not migrate their
applications to 64 bit. For them, this is a regression from RHEL4.

Comment 1 Larry Troan 2007-03-22 23:07:51 UTC
From Amit at Dell:
Attaching the sos report from a PE6950 with 64 GB RAM that is loaded
with RHEL5 32-bit. kernel-PAE sees all 64GB.

Comment 2 Larry Troan 2007-03-22 23:09:05 UTC
Created attachment 150707 [details]
sos -- Kernel-PAE.tar.bz2

Comment 3 RHEL Product and Program Management 2007-04-25 18:48:44 UTC
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.

Comment 6 Larry Troan 2007-05-31 01:47:52 UTC
The problem here is that there is no warning that the customer is running an
invalid configuration in RHEL5. 

The 2.6.18 kernel will boot and appears to run with memory as large as 64GB. In
RHEL3 and RHEL44, you could boot a 24GB kernel but it would likely behave poorly
and the kernel would not even boot at 32GB.

The first time the customer is aware that a valid RHEL4 configuration (albeit
using the hugemem kernel) is now invalid in RHEL5 is when he/she calls Support
and they relate that >16GB is not supported in 32 bit mode on RHEL5. 

It is also not clear that all applications can run or are certified in 32 bit
mode on a 64 bit OS for RHEL5. This could be a significant customer migration
problem to RHEL5.

Comment 7 RHEL Product and Program Management 2007-08-13 19:52:36 UTC
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request. 


Note You need to log in before you can comment on or make changes to this bug.