Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233533 - mock default cfg for fedora-1-i386 does not cause inclusion of build macros
Summary: mock default cfg for fedora-1-i386 does not cause inclusion of build macros
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora Hosted Projects
Classification: Retired
Component: mock
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Clark Williams
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-22 22:24 UTC by Bernard Johnson
Modified: 2013-01-10 04:13 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-03-07 22:15:12 UTC


Attachments (Terms of Use)
root.log showing rpm not being installed (deleted)
2007-03-22 22:24 UTC, Bernard Johnson
no flags Details

Description Bernard Johnson 2007-03-22 22:24:33 UTC
Description of problem:
When fedora-1 rpms are built with the default fedora-1-i386-core.cfg file, the
buildsys-macros rpm is not included as part of the mock root.

Example root.log attached.

Workaround:
Add this to the fedora-1-i386-core.cfg file:
config_opts['chroot_setup_cmd'] = 'groupinstall build build-minimal'

Version-Release number of selected component (if applicable):
mock-0.6.11-1.fc6

How reproducible:
Always

Comment 1 Bernard Johnson 2007-03-22 22:24:33 UTC
Created attachment 150704 [details]
root.log showing rpm not being installed

Comment 2 Clark Williams 2007-03-25 15:15:34 UTC
Still not sure why this is happening, since the "build" group from the FC1
buildroots.xml looks valid (it references the "build-minimal" group, which
contains the buildsys-macros reference).

Comment 3 Clark Williams 2008-03-07 22:15:12 UTC
Closing since FC1 no longer supported


Note You need to log in before you can comment on or make changes to this bug.