Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233527 - screen sets /var/run/screen with problem permissions
Summary: screen sets /var/run/screen with problem permissions
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: screen
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Marcela Mašláňová
QA Contact: Brock Organ
URL:
Whiteboard:
: 233973 234014 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-22 21:55 UTC by g. artim
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-26 13:16:45 UTC


Attachments (Terms of Use)

Description g. artim 2007-03-22 21:55:41 UTC
Description of problem:
after install get error with starting screen, 
Directory '/var/run/screen' must have mode 777.

Version-Release number of selected component (if applicable):
Screen version 4.00.03 (FAU) 23-Oct-06

How reproducible:
not sure if is initially ran screen from root user
before running as a 'normal user', but could be 
related to it not showing up in testing.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Robert Scheck 2007-03-24 12:31:19 UTC
Same here, you broke screen between 4.0.3-3 and 4.0.3-4, please fix immediately.

Comment 2 Robert Scheck 2007-03-24 12:33:38 UTC
Please replace the following (wrongly fixed line)

  %attr(755,root,screen) %{_localstatedir}/run/screen

by that one we've now for years working:

  %attr(0777,root,screen) %{_localstatedir}/run/screen

Comment 3 Marcela Mašláňová 2007-03-26 13:16:45 UTC
Fixed in screen-4.0.3-5.

Comment 4 Marcela Mašláňová 2007-03-26 13:33:33 UTC
*** Bug 233973 has been marked as a duplicate of this bug. ***

Comment 5 Marcela Mašláňová 2007-03-27 11:44:34 UTC
*** Bug 234014 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.