Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233525 - Floating exception in print_by_column() with unprintable characters
Summary: Floating exception in print_by_column() with unprintable characters
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: tcsh
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Vitezslav Crhonek
QA Contact: Bill Huang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-22 21:47 UTC by Alasdair Kergon
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-06-05 20:33:36 UTC


Attachments (Terms of Use)

Description Alasdair Kergon 2007-03-22 21:47:41 UTC
My FC6 shell core-dumped.

6.14-12

Reproduced with RHEL5:

> set autolist
> mkdir tmp
> cd tmp
> touch <^V><^H><^V><^H>
<TAB>

NLSStringWidth(items[i]) returns -1 cast to unsigned int so maxwidth =
4294967295 and wins max() every time;

no_file_suffix is 1 => maxwidth += 1 => maxwidth = 0;

columns = TermH / maxwidth

Comment 1 Vitezslav Crhonek 2007-04-24 12:16:39 UTC
Hi,

I can't reproduce it:

> set autolist
> mkdir tmp2
> cd tmp2
> touch ^V^H^V^H
> ^V^H^V^H ^V^H^V^H ^V^H^V^H ...

Am I doing something wrong?


Comment 2 Vitezslav Crhonek 2007-04-24 12:18:59 UTC
Now it works, sorry... My fault.

Comment 3 Alasdair Kergon 2007-04-24 14:18:38 UTC
sorry - you need more than one item in the directory for the tabbing to 
display a list of possibilities

add another 'touch xyz'

Comment 5 RHEL Product and Program Management 2007-06-05 20:33:36 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Since this
bugzilla is in a component that is not approved for the current
release, it has been closed with resolution deferred.  You may
reopen this bugzilla for consideration in the next release.


Note You need to log in before you can comment on or make changes to this bug.