Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233523 - libboost_python needs rebuild against python 2.5
Summary: libboost_python needs rebuild against python 2.5
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: boost
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Benjamin Kosnik
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC7Blocker 233782
TreeView+ depends on / blocked
 
Reported: 2007-03-22 21:38 UTC by Hans de Goede
Modified: 2013-08-09 05:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-29 19:16:43 UTC


Attachments (Terms of Use)
PATCH fixing boost compilation on x86_64 with python 2.5 (deleted)
2007-03-24 10:16 UTC, Hans de Goede
no flags Details | Diff

Description Hans de Goede 2007-03-22 21:38:41 UTC
Hi,

I just tried to compile an application which uses libboost_python and that
failed because libboost_python expect the application to get linked against
/usr/lib/libpython2.4.so.1.0, but it is getting linked against
/usr/lib/libpython2.5.so.1.0

So please rebuild boost ASAP (before Fedora 7 gets released) also since
libboost_python needs symbols from /usr/lib/libpython.so it should get linked
against it. If this had been done earlier then this breakage would have been
caught way earlier too, through rpm deps breaking.

Comment 1 Hans de Goede 2007-03-24 10:16:52 UTC
Created attachment 150821 [details]
PATCH fixing boost compilation on x86_64 with python 2.5

I found this patch from opensuse, which fixes compiling boost on x86_64 with
python 2.5

Comment 2 Benjamin Kosnik 2007-03-27 17:37:21 UTC
Hey Hans. I rebuilt boost-1.33.1-12, it's too late for fc7t3 but will be in fc7.
This should show up on the rawhide build lists soon.

The build issue with linking libboost_python is on hold for the moment.

best,
benjamin

Comment 3 Hans de Goede 2007-03-27 19:03:30 UTC
(In reply to comment #2)
> Hey Hans. I rebuilt boost-1.33.1-12, it's too late for fc7t3 but will be in fc7.
> This should show up on the rawhide build lists soon.
> 
> The build issue with linking libboost_python is on hold for the moment.
> 

I don't understand, if you've build a new boost all is well. Or you mean the
fact that -lpython should be added to the libboost_python LDFLAGS/LIBS? If that
is what you mean I think thats best tracked in the review bug, and this one can
be closed.



Comment 4 Benjamin Kosnik 2007-03-28 10:06:33 UTC
> Or you mean the fact that -lpython should be added to the libboost_python 
> LDFLAGS/LIBS?

Yes, this. I added it to the review bug. When the rebuilt boost shows up, you
can close this if you are satisfied.

best,
benjamin

Comment 5 Hans de Goede 2007-03-29 19:03:50 UTC
I can confirm this is fixed, closing



Note You need to log in before you can comment on or make changes to this bug.