Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233492 - ssh-add no longer run
Summary: ssh-add no longer run
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: comps
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-22 18:54 UTC by Andrew Overholt
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-22 20:59:00 UTC


Attachments (Terms of Use)

Description Andrew Overholt 2007-03-22 18:54:46 UTC
Description of problem:
I am running rawhide on a box with the same homedir I had under fc6.  ssh-add is
listed in my System->Preferences->Personal->Sessions under "Additional Programs"
and is enabled.

Version-Release number of selected component (if applicable):
gnome-session-2.18.0-1.fc7.i386

How reproducible:
Always; since at least F7t2

Steps to Reproduce:
1. Add ssh-add to list of programs to run on startup in session tool
2. Log out
3. Log in
  
Actual results:
No ssh-add gui like with FC6

Expected results:
ssh-add gui key password prompting thing

Additional info:

Comment 1 Ray Strode [halfline] 2007-03-22 20:26:34 UTC
do you have ssh-askpass-gnome installed?

Comment 2 Andrew Overholt 2007-03-22 20:34:07 UTC
(In reply to comment #1)
> do you have ssh-askpass-gnome installed?

I don't see that available anywhere.

Comment 3 Ray Strode [halfline] 2007-03-22 20:55:43 UTC
I'm sorry, I meant:

openssh-askpass

which includes the binary /usr/libexec/openssh/gnome-ssh-askpass

also what is the output of
echo $SSH_ASKPASS ?

Comment 4 Andrew Overholt 2007-03-22 20:59:00 UTC
(In reply to comment #3)
> openssh-askpass
> 
> which includes the binary /usr/libexec/openssh/gnome-ssh-askpass

Thanks, that was it.  Was this part of a default install before or something?  I
installed via the test2 Live CD.

Comment 5 Ray Strode [halfline] 2007-03-23 00:05:59 UTC
Not sure, very possibly.


Note You need to log in before you can comment on or make changes to this bug.