Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233474 - Logrotate has spurious endscript
Summary: Logrotate has spurious endscript
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: samba
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Simo Sorce
QA Contact: David Lawrence
URL:
Whiteboard:
: 233809 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-22 17:54 UTC by Dan Young
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-22 19:52:35 UTC


Attachments (Terms of Use)
Logrotate patch (deleted)
2007-03-22 17:57 UTC, Dan Young
no flags Details | Diff

Description Dan Young 2007-03-22 17:54:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.2) Gecko/20070312 Firefox/2.0.0.2

Description of problem:
The "Remove kill -HUP from rotate, samba use -HUP for other things noit to reopen logs" change in 3.0.24-3.fc7 left the endscript at the end of /etc/logrotate.d/samba. It's only needed after a "postrotate" or similar, which was removed per the changelog.

Version-Release number of selected component (if applicable):
samba-3.0.24-6.fc7

How reproducible:
Always


Steps to Reproduce:
1. Install samba
2. Run /etc/cron.daily/logrotate

Actual Results:
/etc/cron.daily/logrotate:

error: samba:6 unknown option 'endscript' -- ignoring line

Expected Results:


Additional info:

Comment 1 Dan Young 2007-03-22 17:57:19 UTC
Created attachment 150681 [details]
Logrotate patch

Comment 2 Simo Sorce 2007-03-22 19:52:35 UTC
Thank you, patch applied to cvs, will be out with the next release.

Comment 3 Simo Sorce 2007-03-25 14:16:17 UTC
*** Bug 233809 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.