Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233472 - anaconda erases /etc/sysconfig/desktop during installation from livecd
Summary: anaconda erases /etc/sysconfig/desktop during installation from livecd
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
: 235429 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-22 17:35 UTC by Sebastian Vahl
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-23 00:54:42 UTC


Attachments (Terms of Use)
Installation log created by anaconda (deleted)
2007-03-22 17:35 UTC, Sebastian Vahl
no flags Details
used kickstart.ks for creation of livecd (deleted)
2007-03-22 17:37 UTC, Sebastian Vahl
no flags Details

Description Sebastian Vahl 2007-03-22 17:35:11 UTC
Description of problem: A livecd has integrated /etc/sysconfig/desktop with 
the content "DESKTOP=KDE". When installing this livecd to 
harddisk, /etc/sysconfig/desktop is empty after the reboot.

Version-Release number of selected component (if applicable): 
anaconda-11.2.0.39-1


How reproducible: Ever

Additional info: /etc/sysconfig/desktop is integrated into the squashfs.img 
and not created during /etc/init.d/livecd. If you boot into another partition 
after the reboot and mount the partition the file is also empty. So it is not 
erased by firstboot.

Comment 1 Sebastian Vahl 2007-03-22 17:35:11 UTC
Created attachment 150676 [details]
Installation log created by anaconda

Comment 2 Sebastian Vahl 2007-03-22 17:37:42 UTC
Created attachment 150677 [details]
used kickstart.ks for creation of livecd

attached used kickstart.ks for creation of livecd

Comment 3 Jeremy Katz 2007-03-23 00:54:42 UTC
Fixed in CVS by not writing out /etc/sysconfig/desktop unless there's an
explicit value it should be set to (which means someone set it via kickstart).  

Comment 4 Sebastian Vahl 2007-04-04 13:03:30 UTC
Finally I was able to test this with anaconda-11.2.0.44-1. It works now. Thanks
for fixing this.

Comment 5 Leighton Brown 2007-04-15 21:48:59 UTC
*** Bug 235429 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.