Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233469 - Missing multilib packages break 32 bit apps in non default nss configurations
Summary: Missing multilib packages break 32 bit apps in non default nss configurations
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution
Version: rawhide
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Bill Nottingham
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-22 16:42 UTC by Simo Sorce
Modified: 2014-03-17 03:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-15 19:56:08 UTC


Attachments (Terms of Use)

Description Simo Sorce 2007-03-22 16:42:40 UTC
Description of problem:
64 bit rawhide is currently broken wrt 32bit apps, when non-default NSS modules
are used. No 32bit NSS lib is provided for nss_ldap, nss_db, nss_winbindd, and
probably many others.
The same is for PAM libs.

Version-Release number of selected component (if applicable):
Rawhide

How reproducible:

I copied a 32 bit version of ls on a system configured to use nss_ldap,
here are the results:

64bit ls:
[root@rapier tmp]# ls -ald /tmp/x86_64
drwxr-xr-x 2 nalin 2516 4096 2007-03-21 16:21 /tmp/x86_64

32bit ls:
[root@rapier tmp]# /tmp/ls32 -ald /tmp/x86_64/
drwxr-xr-x 2 2510 2516 4096 Mar 21 16:21 /tmp/x86_64/

Excerpt of /tmp/ls32 strace:

open("/lib/i686/libnss_ldap.so.2", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/lib/libnss_ldap.so.2", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/sse2/libnss_ldap.so.2", O_RDONLY) = -1 ENOENT (No such file or
directory)
open("/usr/lib/libnss_ldap.so.2", O_RDONLY) = -1 ENOENT (No such file or directory)


As you can see the user name is not resolved and that's because no 32bit lib is
installed for nss_ldap. The user is provided to the system via nss_ldap of course.


Steps to Reproduce:
1. configure a 64bit system to use nss_ldap
2. use a 32bit app that needs to enumerate or resolve users

Comment 1 Bill Nottingham 2007-05-15 19:56:08 UTC
Looking at the current rawhide x86_64 tree, nss_ldap, nss_db, and samba-common
are all provided as multlib packages.


Note You need to log in before you can comment on or make changes to this bug.