Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233409 - FC-devel install
Summary: FC-devel install
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: libvirt
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Veillard
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-22 07:00 UTC by Florian La Roche
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-22 09:39:59 UTC


Attachments (Terms of Use)

Description Florian La Roche 2007-03-22 07:00:31 UTC
Description of problem:

Installation of the FC-devel rpm gives:
ln: creating symbolic link `/etc/libvirt/qemu/networks/autostart/default.xml':
No such file or directory



Possible fix:
--- libvirt.spec        16 Mar 2007 19:44:21 -0000      1.49
+++ libvirt.spec        22 Mar 2007 06:58:40 -0000
@@ -77,7 +77,7 @@ install -d -m 0755 $RPM_BUILD_ROOT%{_loc
 # We don't want to install /etc/libvirt/qemu/networks in the main %files list
 # because if the admin wants to delete the default network completely, we don't
 # want to end up re-incarnating it on every RPM upgrade.
-install -d -m 0755 $RPM_BUILD_ROOT%{_datadir}/libvirt/networks/
+install -d -m 0755 $RPM_BUILD_ROOT%{_datadir}/libvirt/networks/autostart
 cp $RPM_BUILD_ROOT%{_sysconfdir}/libvirt/qemu/networks/default.xml \
    $RPM_BUILD_ROOT%{_datadir}/libvirt/networks/default.xml
 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/libvirt/qemu/networks/default.xml
@@ -125,7 +125,7 @@ fi
 %{_libdir}/lib*.so.*
 %dir %attr(0700, root, root) %{_sysconfdir}/libvirt/
 %dir %attr(0700, root, root) %{_sysconfdir}/libvirt/qemu/
-%dir %attr(0700, root, root) %{_sysconfdir}/libvirt/qemu/networks/
+%dir %attr(0700, root, root) %{_sysconfdir}/libvirt/qemu/networks/autostart
 %{_sysconfdir}/rc.d/init.d/libvirtd
 %dir %{_datadir}/libvirt/
 %dir %{_datadir}/libvirt/networks/



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Daniel Veillard 2007-03-22 09:39:59 UTC
I tried to fix it in libvirt CVS already by just adding the
%dir %attr(0700, root, root) %{_sysconfdir}/libvirt/qemu/networks/autostart
line, I will also add the extra install line, this looks safer.

  thanks !

Daniel


Note You need to log in before you can comment on or make changes to this bug.