Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233404 - %{_libdir}/pm-utils/bin/pm-action contains hardcoded /usr/lib
Summary: %{_libdir}/pm-utils/bin/pm-action contains hardcoded /usr/lib
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pm-utils
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-22 05:39 UTC by Michel Alexandre Salim
Modified: 2015-03-05 01:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-08-31 09:05:49 UTC


Attachments (Terms of Use)

Description Michel Alexandre Salim 2007-03-22 05:39:08 UTC
Description of problem:
Line 86 of pm-action reads
. /usr/lib/pm-utils/functions

This breaks on 64-bit platforms where the file is in /usr/lib64/pm-utils, and
seems to be a regression - in the previous version files were under /etc/pm

Version-Release number of selected component (if applicable):
pm-utils-0.99.2-1.fc7

How reproducible:
Always

Steps to Reproduce:
1. Run pm-suspend or pm-hibernate
  
Actual results:
Fails since functions cannot be loaded

Expected results:
Suspends / hibernates properly

Additional info:
Should pm-utils not be noarch?

Comment 1 Till Maas 2007-03-22 09:06:48 UTC
(In reply to comment #0)

> Additional info:
> Should pm-utils not be noarch?

pm-utils contains radeontool and vbetool, which are both (c?) binaries, so this
is not an option.

Comment 2 Till Maas 2007-08-31 09:05:49 UTC
(In reply to comment #0)
> Description of problem:
> Line 86 of pm-action reads
> . /usr/lib/pm-utils/functions
> 
> This breaks on 64-bit platforms where the file is in /usr/lib64/pm-utils, and

The current devel spec installs stuff always in /usr/lib and never in
/usr/lib64, so this bug should be solved.


Note You need to log in before you can comment on or make changes to this bug.