Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233403 - ooimpress/oowriter crashes while Pasting/Opeing, Closing a document
Summary: ooimpress/oowriter crashes while Pasting/Opeing, Closing a document
Status: CLOSED DUPLICATE of bug 233361
Alias: None
Product: Fedora
Classification: Fedora
Version: rawhide
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
Depends On: 231719
TreeView+ depends on / blocked
Reported: 2007-03-22 05:35 UTC by A S Alam
Modified: 2013-07-03 00:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2007-03-25 17:19:17 UTC

Attachments (Terms of Use)

Description A S Alam 2007-03-22 05:35:08 UTC
+++ This bug was initially created as a clone of Bug #231719 +++

Description of problem:

ooimpress crashes while closing a document

---start copy and paste here-
(I) loaded video driver of...
(II) Loading /usr/lib/xorg/modules/drivers/
(III)  Desktop is: GNOME
(IV)   libgcj version is: libgcj-4.1.1-51.fc6-i386
(V)    kernel is: Linux 2.6.18-1.2798.fc6 #1 SMP Mon Oct 16 14:54:20 EDT 2006
i686 i686 i386
(VI) core rpm version is:
(VII)  depth of root window:    24 planes
(VIII) accessibility is: false
(VIV)  fedora release is: Fedora Core release 6 (Zod)
...start sestatus details ...
SELinux status:                 enabled
SELinuxfs mount:                /selinux
Current mode:                   enforcing
Mode from config file:          enforcing
Policy version:                 21
Policy from config file:        targeted
...end sestatus details ...
...start stackreport details ...
0x4ef32f28: /usr/lib/openoffice.org2.0/program/ + 0x22f28
0x4ef33bbb: /usr/lib/openoffice.org2.0/program/ + 0x23bbb
0x20d420:  + 0x420 (__kernel_sigreturn + 0x0)
0x42625578: /usr/lib/openoffice.org2.0/program/ + 0x689578
(SdrAttrObj::~SdrAttrObj() + 0x28)
0x426270dd: /usr/lib/openoffice.org2.0/program/ + 0x68b0dd
(SdrTextObj::~SdrTextObj() + 0x7d)
0x4263579a: /usr/lib/openoffice.org2.0/program/ + 0x69979a
(SdrRectObj::~SdrRectObj() + 0x4a)
0x427048fd: /usr/lib/openoffice.org2.0/program/ + 0x7688fd
(SdrObjList::Clear() + 0xad)
0x42705167: /usr/lib/openoffice.org2.0/program/ + 0x769167
(SdrObjList::~SdrObjList() + 0x37)
0x42705688: /usr/lib/openoffice.org2.0/program/ + 0x769688
(SdrPage::~SdrPage() + 0x1a8)
0x42761f48: /usr/lib/openoffice.org2.0/program/ + 0x7c5f48
(FmFormPage::~FmFormPage() + 0x58)
0x4327ff66: /usr/lib/openoffice.org2.0/program/ + 0x23ff66
(SdPage::~SdPage() + 0x136)
0x426f0427: /usr/lib/openoffice.org2.0/program/ + 0x754427
(SdrModel::DeletePage(unsigned short) + 0x27)
0x43263ded: /usr/lib/openoffice.org2.0/program/ + 0x223ded
0x426f1e72: /usr/lib/openoffice.org2.0/program/ + 0x755e72
(SdrModel::ClearModel(unsigned char) + 0x52)
0x4326098f: /usr/lib/openoffice.org2.0/program/ + 0x22098f
0x4322ebaf: /usr/lib/openoffice.org2.0/program/ + 0x1eebaf
(sd::DrawDocShell::~DrawDocShell() + 0xff)
0x4f4cf598: /usr/lib/openoffice.org2.0/program/ + 0x6f598
(SvRefBase::QueryDelete() + 0x18)
0x4edb9513: /usr/lib/openoffice.org2.0/program/ + 0x12513
(SotObject::QueryDelete() + 0x33)
0x41c6799e: /usr/lib/openoffice.org2.0/program/ + 0x24c99e
0x41c7860f: /usr/lib/openoffice.org2.0/program/ + 0x25d60f
(SfxTopViewFrame::~SfxTopViewFrame() + 0x4f)
0x41c77b51: /usr/lib/openoffice.org2.0/program/ + 0x25cb51
(SfxTopViewFrame::Close() + 0x61)
0x41c55b0d: /usr/lib/openoffice.org2.0/program/ + 0x23ab0d
0x41c81f17: /usr/lib/openoffice.org2.0/program/ + 0x266f17
(SfxBaseController::dispose() + 0x487)
0x432f4de7: /usr/lib/openoffice.org2.0/program/ + 0x2b4de7
0x42c45274: /usr/lib/openoffice.org2.0/program/ + 0x72274
0x42c4478f: /usr/lib/openoffice.org2.0/program/ + 0x7178f
0x42c1a7e0: /usr/lib/openoffice.org2.0/program/ + 0x477e0
0x42c7c317: /usr/lib/openoffice.org2.0/program/ + 0xa9317
0x42c7cf08: /usr/lib/openoffice.org2.0/program/ + 0xa9f08
0x42c7d344: /usr/lib/openoffice.org2.0/program/ + 0xaa344
0x4fa582d5: /usr/lib/openoffice.org2.0/program/ + 0x2e42d5
0x4f9f5de6: /usr/lib/openoffice.org2.0/program/ + 0x281de6
0x9fd381: /usr/lib/openoffice.org2.0/program/ + 0x50381
(SalDisplay::DispatchInternalEvent() + 0xb1)
0xe7ed06: /usr/lib/openoffice.org2.0/program/ + 0xfd06
0xe7ed41: /usr/lib/openoffice.org2.0/program/ + 0xfd41
0x4e50f6e1: /lib/ + 0x296e1
0x4e511442: /lib/ + 0x2b442 (g_main_context_dispatch + 0x182)
0x4e51441f: /lib/ + 0x2e41f
0x4e514985: /lib/ + 0x2e985 (g_main_context_iteration + 0x65)
0xe80c31: /usr/lib/openoffice.org2.0/program/ + 0x11c31
0x9fe8a7: /usr/lib/openoffice.org2.0/program/ + 0x518a7
(X11SalInstance::Yield(bool, bool) + 0x37)
0x4f809618: /usr/lib/openoffice.org2.0/program/ + 0x95618
(Application::Yield(bool) + 0x68)
0x4f8096ec: /usr/lib/openoffice.org2.0/program/ + 0x956ec
(Application::Execute() + 0x3c)
0x42f65359: /usr/lib/openoffice.org2.0/program/ + 0x26359
(desktop::Desktop::Main() + 0x1779)
0x4f80f1bc: /usr/lib/openoffice.org2.0/program/ + 0x9b1bc
0x4f80f2c5: /usr/lib/openoffice.org2.0/program/ + 0x9b2c5
(SVMain() + 0x35)
0x42f56a69: /usr/lib/openoffice.org2.0/program/ + 0x17a69 (sal_main
+ 0x59)
0x42f56af4: /usr/lib/openoffice.org2.0/program/ + 0x17af4 (main + 0x44)
0x4e115f2c: /lib/ + 0x15f2c (__libc_start_main + 0xdc)
0x80484a1: /usr/lib/openoffice.org2.0/program/simpress.bin + 0x4a1
...end stackreport details ...
...start sample ldd details ... =>  (0x00fc6000) => /usr/lib/openoffice.org2.0/program/
(0x00559000) =>
/usr/lib/openoffice.org2.0/program/ (0x002f9000) => /usr/lib/openoffice.org2.0/program/
(0x00242000) => /lib/ (0x00319000) => /lib/ (0x007fe000) =>
/usr/lib/openoffice.org2.0/program/ (0x00110000) => /usr/lib/ (0x00b5e000) => /lib/ (0x00dc0000) => /lib/ (0x009a8000) => /lib/ (0x003bb000) => /lib/ (0x001d7000)
        /lib/ (0x4d731000)
...end sample ldd details ...
---end copy and paste here---

-- Additional comment from on 2007-03-12 04:34 EST --
Does this happen every time you close any presentation, or just with one
particular one (if so then attach the offender), or is it not reproducible ?

-- Additional comment from on 2007-03-12 13:25 EST --
Created an attachment (id=149847)
document that sometimes crashes on close

-- Additional comment from on 2007-03-12 13:27 EST --
it has happened more than once.  i've tried to intentionally recreate the crash
and I am unable to.

-- Additional comment from on 2007-03-12 13:48 EST --
Do you think any of the following scenarios are the most likely...

crashed after I exited when I had been...
a) just displaying the presentation full screen, I didn't make any changes to
the presentation
b) had been editing the presentation in the "normal" tab and was in that tab
when I exited
c) had been editing the presentation in the "outline" tab and was in that tab
when I exited
d) had been doing a mixture of editing and viewing

It's not crashing for me, but I can see from the trace that it's due to deleting
a SdrTextObj which (unfortunately) is just the editable area of a drawing
object, and so there's loads of them in this document, but it might also be one
in e.g. the "undo" list if one was deleted. So I'm trying to determine if this
might be due to some editing scenario. 

-- Additional comment from on 2007-03-12 13:53 EST --
I managed to reproduce it. The attached file crashed on exit every time for me.
I open a document and then close the application. No editing, no viewing .... 

-- Additional comment from on 2007-03-12 13:54 EST --
I was mostly viewing... ocassionally flipping to full screen, but mostly paging
through the slides (using page-up and page-down keys) in "normal" view,
occassionally copying and pasting the exercises to a text editor as I worked
through the slides to learn TaskJuggler.  I think there were a few times where I
unintentionally changed a slide or deleted text.

-- Additional comment from on 2007-03-22 01:34 EST --
cloning for rawhide (Devel)

Comment 1 A S Alam 2007-03-22 05:36:28 UTC
confirm issue with following package:

some error on terminal is like:
/usr/lib/ symbol lookup error:
/usr/lib/ undefined symbol:

may be different issue

Comment 2 Caolan McNamara 2007-03-25 17:19:17 UTC
Yeah, not quite, the cloning was on the spell check ABI mismatch, and as such
this is a dup of 233361. The original problem of the first trace is still not

*** This bug has been marked as a duplicate of 233361 ***

Note You need to log in before you can comment on or make changes to this bug.