Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233399 - [Areca RHEL 4.6] Add support for Areca RAID controllers (include arcmsr driver from 2.6.19)
Summary: [Areca RHEL 4.6] Add support for Areca RAID controllers (include arcmsr drive...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Tomas Henzl
QA Contact: Martin Jenner
URL:
Whiteboard:
Depends On: 205897 233056
Blocks: 242113
TreeView+ depends on / blocked
 
Reported: 2007-03-22 04:28 UTC by nickcheng
Modified: 2018-10-19 20:53 UTC (History)
14 users (show)

Fixed In Version: RHBA-2007-0791
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-15 16:22:26 UTC
Target Upstream Version:


Attachments (Terms of Use)
The patch for Areca driver, arcmsr-1.20.00.13, in RHEL4 (deleted)
2007-05-17 02:21 UTC, nickcheng
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0791 normal SHIPPED_LIVE Updated kernel packages available for Red Hat Enterprise Linux 4 Update 6 2007-11-14 18:25:55 UTC

Description nickcheng 2007-03-22 04:28:38 UTC
Description of problem:
Please help Areca SAS/SATA-RAID driver backport to RHEL4.

Comment 1 nickcheng 2007-03-23 05:43:13 UTC
This bug is dependent on "Bugzilla Bug 233056: Add support for Areca RAID
controllers (include arcmsr driver from 2.6.19) "
Please refer to it.
Thanks,

Comment 2 Andrius Benokraitis 2007-03-23 07:06:15 UTC
Bug 205897 is also dependent on this bug, since RHEL 5.1 is slated to be in
development before RHEL 4.6.

Comment 3 Tom Coughlan 2007-04-26 16:18:19 UTC
Backporting this driver to the 2.6.9 kernel may require some significant effort.
There will also be on-going support costs for this in RHEL 4. I do not believe
we currently have the business case to justify that cost and effort. Customers
who want to run this adapter will be able to move to RHEL 5 to get support for it. 

Comment 4 Nick Cheng 2007-04-27 01:56:22 UTC
Tom
Actually we still have a lot of customers whom got business on NAS system that
is based on kernel 2.6.9-xx.
It will cost them a lot of time if moving to latter kernel version.
I still not hear they would invest in that.
The request for the driver disk still remains.
Sincerely hope Redhat could take it into consideration. 

Comment 5 Jan Iven 2007-05-14 14:58:57 UTC
Customers (i.e. us) really would like this (see e.g. our IT#79615) even on
RHEL4. Please consider reopening.

Comment 6 dijuremo 2007-05-14 15:23:16 UTC
RHEL4 still has about 5 years of life (based on the 7 year lifespan for each
version of RHEL, right?) so adding it to the release kernel in future RHEL4
updates would really simplify the lives of many sysadmins who have to manually
compile and add the module each time the kernel is updated.  

I would also like to ask you to reconsider adding it to a future RHEL4 update.

Comment 8 dijuremo 2007-05-15 15:33:58 UTC
Nick,

Can you confirm if the patch for RHEL4 would be identical to the one you
submitted for RHEL5? I believe the driver code is the same, so there would not
be any extra effort needed to maintain two separate patches, but I have not
studied the complete source code for the areca driver, I still believe it is
very similar if not identical.

Is anyone from Red Hat considering looking at reopening this request?



Comment 9 nickcheng 2007-05-16 03:42:02 UTC
Diego,
They are very similar, but a little bit diffenert.
I will make time to build the patch these days. 

Comment 10 nickcheng 2007-05-17 02:21:12 UTC
Created attachment 154890 [details]
The patch for Areca driver, arcmsr-1.20.00.13, in RHEL4

Comment 12 nickcheng 2007-05-21 07:56:45 UTC
Hi Tom,
Are there anybody in charge of this project?
Actually there are still a lot of customers running on RHEL4.


Comment 13 Tom Coughlan 2007-05-31 14:21:24 UTC
Okay, okay... I see there is plenty of interest in this for RHEL 4. I will
re-open this, and we will attempt to get it done in 4.6. If there are any
glitches whatsoever, in either 5.1 or 4.6, then we may need to defer this until
after 4.6. 

Comment 14 RHEL Product and Program Management 2007-05-31 14:24:56 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 15 Tomas Henzl 2007-06-04 08:50:42 UTC
Nick,

please could you specify on which RHEL architectures Areca
has tested and will support this driver ? 
I expect that as for 5.1 it will be the x86_64, i686 and PowerPC.

Tomas




Comment 16 nickcheng 2007-06-04 09:35:03 UTC
Yes,
It is the same with the driver in RHEL5, i.e. x86_64、i686、Sparc、Sparc64、PowerPC.

Comment 17 Baif 2007-06-04 16:40:24 UTC
Hi. I had test the arcmsr.1.20.0X.13 ,arcmsr.1.20.0X.14 on "RHEL 4 update 4, 
update 5, x86_64) with SMP kernel, 4GB memory or more, onn Intel XEN platform 
with EM64T and Hyper-Threading.

Looping with CLI V1.72.250_70306 or the API call to 
ArcLib(Arclib_Build250_70306) will cause memory exhausted and unload the 
arcmsr module would NOT free the memory had been "used". 

Hank from Areca Inc. had confirmed that, and he said:
"the problem was gone when using the kernel 2.6.18 even the memory size > 4G 
and intel platform". And he "guess this may the bug of kernel of 2.6.9 on 
intel platform".

But I think that would be some bugs in arcmsr.1.20.0X.13 or arcmsr.1.20.0X.14.
SO where are the bugs?


The Makefile for compiling outside the kernel source tree hand been tested:
==========================================
obj-m := arcmsr.o
KDIR := /lib/modules/$(shell uname -r)/build
PWD := $(shell pwd)
default:
$(MAKE) -C $(KDIR) SUBDIRS=$(PWD) modules
==========================================

Comment 18 Baif 2007-06-05 04:14:20 UTC
The problem will not happen on AMD platform. RHEL 4 update 4, update 5 SMP 
with 8GB memory had been done and the problem did NOT come up.

Comment 19 Tomas Henzl 2007-06-05 12:51:33 UTC
Nick,
please take a look at the memory error. 
Thanks Tomas

Comment 20 nickcheng 2007-06-05 12:55:04 UTC
Yes, we have post a patch to the customer.
Actually it doesn't come up in the version that we post to RedHat.

Comment 22 RHEL Product and Program Management 2007-06-19 12:54:12 UTC
This request was evaluated by Red Hat Kernel Team for inclusion in a Red
Hat Enterprise Linux maintenance release, and has moved to bugzilla 
status POST.

Comment 23 nickcheng 2007-07-03 02:05:14 UTC
Hi guys,
I heard RH complains Areca delays the process.
Is it true?
If yes, please let me know where.

Comment 24 Andrius Benokraitis 2007-07-05 19:41:07 UTC
Nick - Can you be more specific? AFAIK, there are no items waiting on Areca
until the driver is added to RHEL 4.6.

Comment 25 nickcheng 2007-07-06 01:33:56 UTC
An important customer in Euro stated that a PM in RH argued Areca slowd the
certification process.
I thought the process came along quite well and I am bewildered by the compliant.   
Therefore I have to inquire the reason why it happened.
I will pass your message to our customer.
Thanks,


Comment 26 Andrius Benokraitis 2007-07-06 03:31:50 UTC
Nick, if you have the name of the Red Hatter you can pass on to me, that would
be great. I am also bewildered as well, since there is no official
"certification" per se on hardware devices or peripherals. This is the first
I've heard of any dissatisfaction on the current strides to include the Areca
driver after formalizing the relationship. Obviously there has been some
clamoring to have the driver included in RHEL, but it was only included into
Fedora recently.

Comment 27 Tomas Henzl 2007-07-06 08:23:30 UTC
Nick, I haven't heard about this, and as for me I'm not complaining.

Comment 29 Jason Baron 2007-07-31 15:49:06 UTC
committed in stream U6 build 55.26. A test kernel with this patch is available
from http://people.redhat.com/~jbaron/rhel4/


Comment 31 John Poelstra 2007-08-29 17:17:47 UTC
A fix for this issue should have been included in the packages contained in the
RHEL4.6 Beta released on RHN (also available at partners.redhat.com).  

Requested action: Please verify that your issue is fixed to ensure that it is
included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

If you cannot access bugzilla, please reply with a message to Issue Tracker and
I will change the status for you.  If you need assistance accessing
ftp://partners.redhat.com, please contact your Partner Manager.

Comment 32 John Poelstra 2007-09-05 22:26:53 UTC
A fix for this issue should have been included in the packages contained in 
the RHEL4.6-Snapshot1 on partners.redhat.com.  

Requested action: Please verify that your issue is fixed to ensure that it is 
included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed, 
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent 
symptoms of the problem you are having and change the status of the bug to 
FAILS_QA.

If you cannot access bugzilla, please reply with a message about your test 
results to Issue Tracker.  If you need assistance accessing 
ftp://partners.redhat.com, please contact your Partner Manager.

Comment 33 nickcheng 2007-09-06 01:47:26 UTC
John,
I cann't get access to the RHEL4 Update 6 x86_64 Beta disk4 from last week. But
there are no problem with other disks 
I retried it for many many times but it always repried with no cache on my FlashGet.
Would you please check it out?

Comment 34 Andrius Benokraitis 2007-09-06 02:41:12 UTC
Nick - did you try the most recent snapshot released today?

Comment 35 Jay Turner 2007-09-07 12:20:15 UTC
Were you attempting to download the Snapshot 1 images?  And which variant
specifically (AS, ES, WS, Desktop) are you seeing problems with?

Comment 36 nickcheng 2007-09-07 12:50:30 UTC
I have downloaded the ISO from
ftp://partners.redhat.com/797f57b13f1626c5e26da50bd1f52300/, which Andrius give
it to me today.
I will test ES variant next Monday.


Comment 37 Nick Cheng 2007-09-11 01:43:59 UTC
We have tested ES x86_64 version yesterday.
It looks good so far.

Comment 39 errata-xmlrpc 2007-11-15 16:22:26 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0791.html



Note You need to log in before you can comment on or make changes to this bug.