Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233389 - Dovecot will not update with yum
Summary: Dovecot will not update with yum
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: dovecot
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Janousek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-22 00:24 UTC by Skip Palin
Modified: 2014-01-21 22:57 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-23 21:51:45 UTC


Attachments (Terms of Use)

Description Skip Palin 2007-03-22 00:24:32 UTC
Description of problem:
[('file /etc/dovecot.conf from install of dovecot-1.0-7.rc27.fc7 conflicts with
file from package dovecot-1.0-3.rc22.fc7', (7, '/etc/dovecot.conf', 0L))

Version-Release number of selected component (if applicable):


How reproducible:
Yum update

Steps to Reproduce:
1.yum update
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Tomas Janousek 2007-03-22 09:57:39 UTC
I'm unable to reproduce this. I bet this is some multilib/yum issue.

When I tried to reproduce it, I had to install mysql to satisfy dovecot dep.
Mysql depended on a newer version of ncurses, but yum decided to update only on
x86_64. This resulted in a conflict. I have no idea how this may happen with
dovecot though, it should not be multilib at all.

Please check what architecture is your currently installed dovecot and try to
rpm -Uvh the new one manully.

Comment 2 Seth Vidal 2007-03-22 12:15:48 UTC
what version of yum is this?

Comment 3 Skip Palin 2007-03-22 12:30:16 UTC
(In reply to comment #2)
> what version of yum is this?

3.1.4

Comment 4 Skip Palin 2007-03-22 12:37:42 UTC
OK so after trying:
rpm -Uvh /var/cache/yum/development/packages/dovecot-1.0-7.rc27.fc7.x86_64.rpm
error: can't create transaction lock on /var/lib/rpm/__db.000

i did a:
]$ rpm -qa | grep dovecot
dovecot-1.0-3.rc22.fc7
dovecot-1.0-3.rc22.fc7

Tried to remove it and get:
 rpm -e dovecot-1.0-3.rc22.fc7
error: "dovecot-1.0-3.rc22.fc7" specifies multiple packages


Comment 5 Tomas Janousek 2007-03-22 13:26:06 UTC
Seems like you have both i386 and x86_64 version of the package installed. I
suppose you must have installed these with --nodeps or something, because these
two collide in at least the /usr/sbin/dovecot binary. This package is not a
multilib one, so this is a conflicting setup even before doing any update at all.

Comment 6 Skip Palin 2007-03-23 21:46:47 UTC
OK
I screed up, when I did a update I used:
yum -y --skip-broken update

Sorry to waste your time.


Note You need to log in before you can comment on or make changes to this bug.