Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233361 - soffice.bin undefined symbol, mismatch of hunspell ABI
Summary: soffice.bin undefined symbol, mismatch of hunspell ABI
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
: 233403 233551 233732 (view as bug list)
Depends On:
Blocks: FC7Blocker
TreeView+ depends on / blocked
 
Reported: 2007-03-21 20:08 UTC by Steve Grubb
Modified: 2013-01-10 04:13 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-29 08:51:32 UTC


Attachments (Terms of Use)

Description Steve Grubb 2007-03-21 20:08:21 UTC
Description of problem:
I open a sxi file and open office shuts down abruptly.

Version-Release number of selected component (if applicable):
openoffice.org-core-2.2.0-12.1

How reproducible:
Every time

Steps to Reproduce:
1. ooffice myfile.sxi

 
Actual results:
/usr/lib64/openoffice.org/program/soffice.bin: symbol lookup error:
/usr/lib64/openoffice.org/program/libspell680lx.so: undefined symbol:
_ZN8Hunspell5spellEPKc


Expected results:
See my document

Additional Info:
Testing on x86_64 machine

Comment 1 Thorsten Leemhuis 2007-03-22 12:13:16 UTC
Confirmed here (also x86_64); also on the list:
https://www.redhat.com/archives/fedora-test-list/2007-March/msg00424.html

Comment 2 Thorsten Leemhuis 2007-03-23 10:39:07 UTC
I looked a bit more into it; downgrading to hunspell-1.1.4-5.fc7.x86_64.rpm  (
ftp://fedora.mirrors.tds.net/pub/fedora-core/development/x86_64/os/Fedora/RPMS/hunspell-1.1.4-5.fc7.x86_64.rpm
) fixes it for me.

Not changing comonent to hunspell for now; hunspell is owned by Caolan, too, and
it is unclear to me if it is a problem in openoffice.org or hunspell.

Comment 3 Thorsten Leemhuis 2007-03-23 10:54:18 UTC
Just wondering: Might be nice to get this fixed for test3

Comment 4 Jesse Keating 2007-03-23 16:49:27 UTC
I'd like to get caolan's input, but I could rollback the hunspell version for Test3.

Comment 5 Guido Ledermann 2007-03-23 17:03:17 UTC
That would really be an alternative.

Comment 6 Caolan McNamara 2007-03-25 16:32:16 UTC
*** Bug 233732 has been marked as a duplicate of this bug. ***

Comment 7 Caolan McNamara 2007-03-25 16:32:42 UTC
*** Bug 233551 has been marked as a duplicate of this bug. ***

Comment 8 Caolan McNamara 2007-03-25 16:39:38 UTC
Typical, the wheels fall off right after I take a day or two holidays :-(

Anyway, I had rebuilt OOo right after I built the latest hunspell so that the
ABI change (but API non-change would be picked up). I guess the OOo build just
took too long, the intention was to have openoffice.org-2.2.0-13.1 which is
rebuilt against the new hunspell.

Comment 9 Caolan McNamara 2007-03-25 17:16:54 UTC
caolanm->jkeating; Either rolling back hunspell, or rolling forward
openoffice.org  to 2.2.0-13.1 for Test3 will fix this. Doesn't really matter
which, but I can't of course do either myself for Test3

Comment 10 Caolan McNamara 2007-03-25 17:19:19 UTC
*** Bug 233403 has been marked as a duplicate of this bug. ***

Comment 11 Thorsten Leemhuis 2007-03-25 17:28:31 UTC
(In reply to comment #9)
> caolanm->jkeating; Either rolling back hunspell, or rolling forward [...]

The rawhide tree currently has 1.14 again:
http://ftp-stud.fht-esslingen.de/pub/Mirrors/fedora.redhat.com/linux/core/development/i386/os/Fedora/hunspell-1.1.4-5.fc7.i386.rpm
(yes, that mirror is up2date)



Note You need to log in before you can comment on or make changes to this bug.