Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233260 - nv driver hangs system on X startup
Summary: nv driver hangs system on X startup
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nv
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-21 11:42 UTC by Ralf Ertzinger
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-11 20:58:20 UTC


Attachments (Terms of Use)
xorg.conf (deleted)
2007-03-21 11:42 UTC, Ralf Ertzinger
no flags Details
Not original reporter. This is with version xorg-x11-drv-nv-2.0.0-2.fc7 (deleted)
2007-03-23 01:50 UTC, Jim Cornette
no flags Details
Log for reverted version of the nv driver installed. (deleted)
2007-03-24 01:57 UTC, Jim Cornette
no flags Details
xorg.log (deleted)
2007-04-17 16:53 UTC, Riku Seppala
no flags Details

Description Ralf Ertzinger 2007-03-21 11:42:20 UTC
Description of problem:
Starting X with the configuration attached below hangs the system.
The last line in xorg.log is

(==) NV(1): Write-combining range (0xe8000000,0x2000000)

(Sorry, no complete crash log at this time)

xorg-x11-drv-nv-1.99.1-2.fc7 works.

The card driven by nv is:
00:0c.0 0300: 10de:002d (rev 15)
        Subsystem: 1102:1046
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 64 (1250ns min, 250ns max)
        Interrupt: pin A routed to IRQ 22
        Region 0: Memory at eb000000 (32-bit, non-prefetchable) [size=16M]
        Region 1: Memory at e8000000 (32-bit, prefetchable) [size=32M]
        Expansion ROM at 50040000 [disabled] [size=64K]
        Capabilities: [60] Power Management version 1
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-



Version-Release number of selected component (if applicable):
xorg-x11-drv-nv-2.0.0-1.fc7

How reproducible:
Always

Steps to Reproduce:
1. Start X with attached config
2.
3.
  
Actual results:
System hangs

Expected results:
normal X startup

Additional info:

Comment 1 Ralf Ertzinger 2007-03-21 11:42:20 UTC
Created attachment 150559 [details]
xorg.conf

Comment 2 Will Woods 2007-03-22 19:03:36 UTC
Can you try xorg-x11-drv-nv-2.0.0-2.fc7, which includes nv-2.0.0-hang-fix.patch?
That fixed the hang on my machine.

Comment 3 Jim Cornette 2007-03-23 01:49:12 UTC
I was getting the lockup of the system prior to xorg-x11-drv-nv-2.0.0-2.fc7.
After this driver I get only 800x600. The system eventually crashes. I'll attach
the log related to the crashed system after time.

Comment 4 Jim Cornette 2007-03-23 01:50:32 UTC
Created attachment 150712 [details]
Not original reporter. This is with version xorg-x11-drv-nv-2.0.0-2.fc7

Comment 5 Jim Cornette 2007-03-23 02:19:30 UTC
Just adding that the action leading to the crash now is the switching to VT screen.

Comment 6 Jim Cornette 2007-03-24 01:54:39 UTC
Just passing on information regarding on the patch that was added. The patch
causes what was supposed to be resolved by the patch. I got lockups with the
patched driver and have good results with no lockup and better resolution with a
rollback to xorg-x11-drv-nv-1.2.2.1-3.fc7.

I believe this feedback provides information regarding the patched version.
Checking box though not bug reporter originator.


Comment 7 Jim Cornette 2007-03-24 01:57:29 UTC
Created attachment 150815 [details]
Log for reverted version of the nv driver installed.

for comparison to lowered resolution logs and VT crashing logs. I will change
to VT afterwards to see if I no longer get a crash when changing to a VT.

Comment 8 Jim Cornette 2007-03-24 01:58:29 UTC
No more VT crashing with earlier nv version.

Comment 9 Will Woods 2007-03-24 16:07:40 UTC
Jim, you're looking at a different bug - you've got a crash, not a hang, and it's happening with driver 
2.0.0-2. Please file that bug separately so we don't confuse the two issues.

Comment 10 Jim Cornette 2007-03-25 00:29:52 UTC
Will file separately for the crash. Thanks!

Comment 11 Riku Seppala 2007-04-17 16:52:17 UTC
Not sure if this is the same bug, but my systems hangs too when starting X. HP
laptop with geforce go 7600. 


Comment 12 Riku Seppala 2007-04-17 16:53:30 UTC
Created attachment 152835 [details]
xorg.log

Comment 13 Riku Seppala 2007-04-20 15:17:28 UTC
I found out that in my case the problem was this
http://bugzilla.kernel.org/show_bug.cgi?id=8186

Comment 14 Adam Jackson 2007-05-11 20:58:20 UTC
Pretty sure Ralf's issue was resolved in 2.0.0-2.  Closing, please reopen if I'm
wrong.


Note You need to log in before you can comment on or make changes to this bug.