Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233251 - RHEL5 Server xen guest can not detect usb devices.
Summary: RHEL5 Server xen guest can not detect usb devices.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests)
Version: 5
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Greg Nichols
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-21 08:47 UTC by Spencer Tsai
Modified: 2008-07-16 21:56 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-26 15:01:29 UTC
Target Upstream Version:


Attachments (Terms of Use)
/var/hts/plan.xml from RHEL5 Server x86_64 xen guest OS (deleted)
2007-03-22 02:20 UTC, Spencer Tsai
no flags Details

Description Spencer Tsai 2007-03-21 08:47:08 UTC
Description of problem:
RHEL5 Server xen guest can not detect usb devices.

Version-Release number of selected component (if applicable):
hts-5.0-31.noarch.rpm

How reproducible:
always

Steps to Reproduce:
1. Install xen guest of RHEL5 Server x86_64 Virtualization platform on SUT.
    SUT is RHEL5 Server x86_64 with xen kernel (Server + Virtualization)
2. In SUT use "xm create GUEST" to active guest domain.
3. Use "virt-manager" to open a console to control xen guest OS.
4. Plug a USB Flash (Sandisk, cruzer mini 256MB, FAT32) to SUT.
5. In SUT use "cat /proc/partitions", SUT always detect USB Flash successfully.
    But in guest OS, it never detects that USB flash.
6. Since guest OS can not detect USB drives,
    hts certify --test=usb on guest OS always failed.

Actual results:
xen guest never detects USB drives.
hts certify --test=usb on guest OS always failed.

Expected results:


Additional info:

Comment 1 Greg Nichols 2007-03-21 12:48:11 UTC
please attach /var/hts/plan.xml from the xen guest.

- Thanks!

Comment 2 Spencer Tsai 2007-03-22 02:20:52 UTC
Created attachment 150638 [details]
/var/hts/plan.xml from RHEL5 Server x86_64 xen guest OS

Sorry, it's my careless to report this bug.
usb test item shows before hts R25 in xen guest; R26 and R31 has fixed.
Please close this bug.
Thank you.


Note You need to log in before you can comment on or make changes to this bug.