Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233247 - USer with UID 50266 cannot login
Summary: USer with UID 50266 cannot login
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: pam
Version: 4.3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Tomas Mraz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-21 07:53 UTC by Vijay
Modified: 2008-01-30 15:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-01-30 15:50:52 UTC


Attachments (Terms of Use)
Strace of sudo su - (deleted)
2007-03-21 19:45 UTC, Vijay
no flags Details
Hope this helps plz see the attachement (deleted)
2007-03-21 20:51 UTC, Vijay
no flags Details

Description Vijay 2007-03-21 07:53:30 UTC
Description of problem:
any USer with UID 50266 cannot login

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux AS release 4 (Nahant Update 3)

How reproducible:


Steps to Reproduce:
1.vi /etc/passwd vi /etc/passwd-
2.change any of the normal user's Login ID to 50266
3.Login as root
4.su - <username> or login as the user
  
Actual results:
Will get a error saying incorrect passwd.

Expected results:
Login sucessfully

Additional info:

Comment 1 Deepak Bhole 2007-03-21 16:21:31 UTC
Changing component.

Comment 2 Tomas Mraz 2007-03-21 17:11:55 UTC
I cannot reproduce this on fully updated RHEL4. Can you strace the su -
<username> and attach the output here?


Comment 3 Vijay 2007-03-21 19:45:50 UTC
Created attachment 150616 [details]
Strace of sudo su -

Plz see the attachement it has the requested strace

Comment 4 Tomas Mraz 2007-03-21 20:08:17 UTC
The strace is unfortunately completely unusable. Is it possible that the strace
is 32bit and the sudo su - 64bit? Or vice versa? Also you mention su - in the
original report and sudo su - in strace?


Comment 5 Vijay 2007-03-21 20:51:48 UTC
Created attachment 150627 [details]
Hope this helps plz see the attachement

Hope this helps plz see the attachement

Comment 6 Tomas Mraz 2007-03-21 20:57:04 UTC
No, not really - the strace is broken - notice the 'umovestr: Input/output
error' messages in every syscall trace.


Comment 7 Vijay 2007-03-22 07:44:45 UTC
(In reply to comment #6)
> No, not really - the strace is broken - notice the 'umovestr: Input/output
> error' messages in every syscall trace.

Can you give me the link so i can download the strace for this? i couldnt find 
it in our repository or online.

thanks
Vijay

Comment 8 Tomas Mraz 2007-03-22 08:19:39 UTC
You should report the problem using your support contact. You can mention this
bugzilla number there.
https://www.redhat.com/apps/support/

This way it can be properly diagnosed and fixed if it is a real problem.

Thank you.



Note You need to log in before you can comment on or make changes to this bug.