Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233245 - anaconda fails with: parted.error: unknown file system type
Summary: anaconda fails with: parted.error: unknown file system type
Keywords:
Status: CLOSED DUPLICATE of bug 233085
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-21 07:25 UTC by Adrian Reber
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-21 13:12:58 UTC


Attachments (Terms of Use)
kickstart file (deleted)
2007-03-21 07:25 UTC, Adrian Reber
no flags Details

Description Adrian Reber 2007-03-21 07:25:57 UTC
Doing a kickstart installation fails with following error:

Greetings.
anaconda installer init version 11.2.0.38 starting
mounting /proc filesystem... done
creating /dev filesystem... done
mounting /dev/pts (unix98 pty) filesystem... done
mounting /sys filesystem... done
anaconda installer init version 11.2.0.38 using a serial console
remember, cereal is an important part of a nutritionally balanced breakfast.

trying to remount root filesystem read write... done
mounting /tmp as ramfs... done
running install...
running /sbin/loader

Welcome to Fedora Core



Running anaconda, the Fedora Core system installer - please wait...
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 565, in <module>
    from exception import handleException
  File "/usr/lib/anaconda/exception.py", line 32, in <module>
    import kickstart
  File "/usr/lib/anaconda/kickstart.py", line 18, in <module>
    from autopart import *
  File "/usr/lib/anaconda/autopart.py", line 19, in <module>
    import fsset
  File "/usr/lib/anaconda/fsset.py", line 838, in <module>
    fileSystemTypeRegister(swapFileSystem())
  File "/usr/lib/anaconda/fsset.py", line 760, in __init__
    self.partedFileSystemType = parted.file_system_type_get("linux-swap")
parted.error: unknown file system type
install exited abnormally [1/1]
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
        /mnt/runtime done
        disabling /dev/loop0
        /proc/bus/usb done
        /proc done
        /dev/pts done
        /sys done
        /tmp/ramfs done
        /selinux done
you may safely reboot your system

Comment 1 Adrian Reber 2007-03-21 07:25:58 UTC
Created attachment 150554 [details]
kickstart file

Comment 2 Dawid Gajownik 2007-03-21 13:12:58 UTC

*** This bug has been marked as a duplicate of 233085 ***


Note You need to log in before you can comment on or make changes to this bug.