Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233233 - TBc3704fb6 rpmdb open failed
Summary: TBc3704fb6 rpmdb open failed
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut
Version: 6
Hardware: i386
OS: Linux
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
Depends On:
TreeView+ depends on / blocked
Reported: 2007-03-21 03:18 UTC by Russ Baker
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: updates
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2007-03-23 15:44:06 UTC

Attachments (Terms of Use)
Zipped tar of db files that may be causing problems (deleted)
2007-03-21 03:18 UTC, Russ Baker
no flags Details

Description Russ Baker 2007-03-21 03:18:34 UTC
+++ This bug was initially created as a clone of Bug #228221 +++

I did a clone of 228221 because it sounds very similar, I'll try to describe my
problem in some detail.

I installed FC6 fresh on a Dell Latitude C600 recently.  Everything went
smoothly.  When I rebooted, I got the expected message that I had 106 updates
available and asked it to start installing them.  The dependencies check runs
fine, the packages get downloaded, and the system says everything installed
successfully.  But when I try to run it again (or the "Install Software" app), I
get the "rpmdb open fail" error below:
Component: Software Updater
Summary: TB6b5e0e87 rpmdb open failed

Traceback (most recent call last):
  File "/usr/sbin/pup", line 659, in ?
  File "/usr/sbin/pup", line 652, in main
    pup = PackageUpdater()
  File "/usr/sbin/pup", line 90, in __init__
    GraphicalYumBase.__init__(self, False)
  File "/usr/lib/python2.4/site-packages/pirut/", line 124, in __init__
  File "/usr/lib/python2.4/site-packages/yum/", line 125, in
    self.conf = config.readMainConfig(startupconf)
  File "/usr/lib/python2.4/site-packages/yum/", line 598, in readMainConfig
    yumvars['releasever'] = _getsysver(startupconf.installroot,
  File "/usr/lib/python2.4/site-packages/yum/", line 661, in _getsysver
    idx = ts.dbMatch('provides', distroverpkg)
TypeError: rpmdb open failed

Local variables in innermost frame:
installroot: /
ts: <rpmUtils.transaction.TransactionWrapper instance at 0x9f25a4c>
distroverpkg: redhat-release

If I reboot, I get a fresh message saying exactly [N - 1] updates are available
(i.e. 105, 104, etc.).  I run it and it downloads everything (again) and
"successfully" installs, but apparently only one package.  I tried selecting
only the pirut and yum packages, which seemed to update OK, but I still have the
same problem.

As described in the comments for the other bug, I tried deleting the db files,
which had the same affect as a reboot (allows me to go, but only one package
installs, then next time I try to run I crash).  Needless to say I don't want to
manually do each of 102 (left) packages, especially since it seems to
re-download them each time.

I've attached my db files in case they're getting corrupted somehow.  Help in
fixing or at least getting around this bug would be much appreciated.

I'm not a savvy Linux guy but I can get by, so if you need more info, let me
know how to get at it and I will.


Description of problem:
i get this error when i updated awhile back but it went away but still no
updates have succeded in installation even though it says it does i also get
this error message when i install an rpm

Version-Release number of selected component (if applicable):

How reproducible:
i think it happened when i did a shutdown after a update yum install didnt shutdown 

Steps to Reproduce:
Actual results:

Expected results:

Additional info:

-- Additional comment from on 2007-02-11 16:32 EST --
Created an attachment (id=147865)
bug dump

-- Additional comment from on 2007-02-12 07:46 EST --
Try doing
    rm -f /var/lib/rpm/__db*

-- Additional comment from on 2007-03-13 07:07 EST --
Is this still occuring.

Comment 1 Russ Baker 2007-03-21 03:18:34 UTC
Created attachment 150550 [details]
Zipped tar of db files that may be causing problems

Comment 2 Russ Baker 2007-03-21 13:23:56 UTC
Running yum with the -t (tolerate errors) option seemed to get through more than
one package before throwing an exception.  I think it got about 6 (went from 100
updates remaining to 94), then threw the same type of PANIC messages.

Also, the exception occurs immediately after installing a package successfully
if I run Add/Remove Software rather than the auto-update selection.

Removing a package has the same symptoms.

Comment 3 Russ Baker 2007-03-22 03:24:20 UTC
I also ran fsck and badblocks on the disk to make sure I don't have any bad
sectors thrown into the mix.

Comment 4 Jeremy Katz 2007-03-23 15:44:06 UTC
This is fixed with newer kernels

Comment 5 Russ Baker 2007-03-23 16:19:11 UTC
Newer as in within the last week?  I ask because I just downloaded and installed
FC6 from the ISO CD images on the mirror sites two weeks ago, so I'm surprised
I'm working with an out-of-date kernel...  I'm not hugely savvy on the Linux
kernel topic in general, so is that normal to have an old buggy kernel
downloaded from the site?  Is there a specific upgrade process I need to follow
that I might have missed?

Glad to hear it's a known, fixed bug though.

Comment 6 Russ Baker 2007-03-25 19:57:56 UTC
Problem solved!  Turns out the problem was that Anaconda installed the i586
kernel the first time around.  I tried updating it, but that didn't seem to
resolve the issue.  So I did a clean re-install and Anaconda selected i686
correctly this time, and everything else seems to have worked out fine.  The
first thing I did was upgrade the kernel using yum, which had to install
multiple packages and didn't have any problem, so I'm pretty sure it was the
i586 kernel that caused the grief.

Note You need to log in before you can comment on or make changes to this bug.