Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233228 - gnome-terminal crashes upon startup
Summary: gnome-terminal crashes upon startup
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-terminal
Version: 6
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Behdad Esfahbod
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-21 02:10 UTC by Kurt Heine
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-23 21:05:24 UTC


Attachments (Terms of Use)

Description Kurt Heine 2007-03-21 02:10:29 UTC
Description of problem:


Version-Release number of selected component (if applicable):
gnome-terminal-2.18.0-1.fc7

How reproducible:
every time

Steps to Reproduce:
1. start gnome-terminal
2.
3.
  
Actual results:

[k@localhost ~]$ gnome-terminal 

(gnome-terminal:3469): Vte-WARNING **: Can not find appropiate font for characte
r U+4e00.


(gnome-terminal:3469): Vte-WARNING **: Can not find appropiate font for characte
r U+4e8c.


(gnome-terminal:3469): Vte-WARNING **: Can not find appropiate font for characte
r U+4e09.


(gnome-terminal:3469): Vte-WARNING **: Can not find appropiate font for characte
r U+56db.


(gnome-terminal:3469): Vte-WARNING **: Can not find appropiate font for characte
r U+4e94.


(gnome-terminal:3469): Vte-WARNING **: Can not find appropiate font for characte
r U+ac00.


(gnome-terminal:3469): Vte-WARNING **: Can not find appropiate font for characte
r U+ac01.


(gnome-terminal:3469): Vte-WARNING **: Can not find appropiate font for characte
r U+ac04.


(gnome-terminal:3469): Vte-WARNING **: Can not find appropiate font for characte
r U+ac08.


(gnome-terminal:3469): Vte-WARNING **: Can not find appropiate font for characte
r U+ac10.

The program 'gnome-terminal' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 1128 error_code 8 request_code 72 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Expected results:
a terminal

Additional info:

It does not happen when using Metacity but only when using beryl.  I notice
there is no beryl in the Components menu.

Comment 1 Will Woods 2007-03-23 17:26:23 UTC
This happening to me, due to a bug in cairo. It should be fixed as of
cairo-1.4.2. Could you please update cairo and gnome-terminal and test again?

Comment 2 Kurt Heine 2007-03-23 21:03:27 UTC
Updated and fixed.  I dont seem to have the problem anymore and gnome-terminal
is working fine.  Thanks.


Note You need to log in before you can comment on or make changes to this bug.