Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233149 - Broken'localhost' mounts in autofs 5.0.1 (0.rc2.15)
Summary: Broken'localhost' mounts in autofs 5.0.1 (0.rc2.15)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: autofs
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Ian Kent
QA Contact: Brock Organ
URL:
Whiteboard:
: 246663 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-20 17:39 UTC by Neil Doane
Modified: 2007-11-30 22:07 UTC (History)
5 users (show)

Fixed In Version: RHBA-2007-0621
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-07 17:30:27 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0621 normal SHIPPED_LIVE autofs bug fix update 2007-10-30 16:17:01 UTC

Description Neil Doane 2007-03-20 17:39:48 UTC
Description of problem:
automount maps with localhost entries, ie:

   logs localhost:/u0/logs

...fail. 


Version-Release number of selected component (if applicable):


How reproducible:
Create a localhost autofs entry in solaris syntax (

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Solaris syntax localhost mounts fail.

Expected results:
compatibility with Solaris's syntax ("localhost:/u0/logs", rather than
":/u0/logs" as autofs5 expects)


Additional info:
Back in autofs4, this was described in the following thread with Ian Kent:

   http:/ /linux.kernel.org/pipermail/autofs/2004-May/001131.html

...and was resolved in the 4.1.3.-4 package at:

   http://people.r edhat.com/~jmoyer/autofs/fc2/4.1.3-4/



---From Ian Kent:
Yes, there was a bug in with this in version 5 which, Jeff and I
resolved, but we didn't know about it before GA cutoff so the fix is not
in the GA release.

However, this needs to work and we do have a fix for it so a bug report
would be really useful.

Ian

Comment 1 Ian Kent 2007-03-21 01:40:38 UTC
It appears that you are using revision 0.rc2.15.
Could you please update to the latest revision, 0.rc2.43.0.2,
and confirm that the problem is still present.

The description in the pipermail thread above no longer
applies as the code concerned has been completely changed
in version 5.

Thanks
Ian


Comment 2 Neil Doane 2007-04-17 18:14:22 UTC
Customer is requesting a hotfix for this for RHEL 5.  Can we move this along any?

Comment 4 RHEL Product and Program Management 2007-04-18 04:24:26 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 9 Kevin Graham 2007-05-23 23:14:58 UTC
Ian -- I don't know if it had been communicated already, but 5.0.1-0.rc2.43.0.2
still exhibits this bug.

Comment 10 Ian Kent 2007-05-24 02:39:06 UTC
(In reply to comment #9)
> Ian -- I don't know if it had been communicated already, but 5.0.1-0.rc2.43.0.2
> still exhibits this bug.

Yes, it has escaped me, I'll have to check what I need to do to
make the hot fix happen, sorry.

Comment 16 Jeff Moyer 2007-05-30 19:16:25 UTC
Setting to MODIFIED as the fix is committed and built.

Comment 17 Ian Kent 2007-05-31 03:45:22 UTC
*** Bug 231954 has been marked as a duplicate of this bug. ***

Comment 19 Kevin Graham 2007-06-04 22:50:15 UTC
Just pushed out the hotfix packages today which did the trick. Thanks, Ian and Neil.

Comment 21 Ian Kent 2007-07-04 02:01:53 UTC
*** Bug 246663 has been marked as a duplicate of this bug. ***

Comment 22 Jerry Uanino 2007-07-04 13:57:16 UTC
Where can the hotfix be obtained?

Comment 26 Jerry Uanino 2007-11-07 14:50:48 UTC
Is there any progress on this. I'm trying to avoid calling the bug into redhat
as a paying customer (which I am) because I'm just going to have to refer them
to an already opened ticket.

Comment 27 Jerry Uanino 2007-11-07 16:03:43 UTC
actually, this is fixed in autofs-5.0.1-0.rc2.55, actually in .44 but no
advisory was put out and the release in the main channel jumped from 43 to 55 so
nobody would know how to get that patch.  Someone should mark this as resolved I
would think.

Comment 28 errata-xmlrpc 2007-11-07 17:30:27 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0621.html



Note You need to log in before you can comment on or make changes to this bug.