Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233145 - ppc64 %{_libdir} value incorrect on power5
Summary: ppc64 %{_libdir} value incorrect on power5
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: rawhide
Hardware: ppc64
OS: Linux
high
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact:
URL:
Whiteboard:
: 160572 208059 (view as bug list)
Depends On:
Blocks: F8Blocker multilib
TreeView+ depends on / blocked
 
Reported: 2007-03-20 17:11 UTC by Dennis Gilmore
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version: 4.4.2-43
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-07-17 19:07:12 UTC


Attachments (Terms of Use)

Description Dennis Gilmore 2007-03-20 17:11:51 UTC
Description of problem:

 target=ppc64 libdir=/usr/lib 
libdir should be /usr/lib64

this effects building ppc64 on Fedora 5, 6 and devel  I can provide a testing 
platform if needed.

I would love to see this fixed for Fedora 7

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jeff Johnson 2007-03-21 04:45:17 UTC
This is fiexed by setting arch from --target in rpm-4.4.6 and later for 6+ months now.

UPSTREAM

Comment 2 Dennis Gilmore 2007-03-26 19:44:55 UTC
This is a blocker for F7 without a fix we wont have a ppc64 release 

Comment 3 Dennis Gilmore 2007-04-03 18:01:17 UTC
Paul the rpm you gave me to test fixes this issue.  can we get packages built 
for FC-6 and devel before Friday please.

Comment 4 Zenon Panoussis 2007-04-04 14:10:24 UTC
I have the opposite problem with %{_lib} :

On a Mac G5 (PPC64),  
rpmbuild --rebuild --target ppc glibc-2.5.12.src.rpm 
...
+ mkdir -p /var/tmp/glibc-2.5-root/lib64/rtkaio
+ mv '/var/tmp/glibc-2.5-root/lib64/librtkaio-*.so' /var/tmp/glibc-2.5-root/lib64/rtkaio/
mv: cannot stat '/var/tmp/glibc-2.5-root/lib64/librtkaio-*.so': No such file or directory

This comes from line 990 in the specfile. "mv $RPM_BUILD_ROOT/%{_lib}/blah...
$RPM_BUILD_ROOT/lib/librtkaio-2.5.so is built as it should be.
$RPM_BUILD_ROOT/lib64/ contains the newly created directory rtkaio and nothing else.

Building with --define "_lib lib" works around the problem. 
Using rpm-build-4.4.2-32 on FC6.

> Paul the rpm you gave me to test fixes this issue.  

Is this rpm publicly available somewhere as a src.rpm?



Comment 5 David Woodhouse 2007-04-10 19:23:16 UTC
*** Bug 160572 has been marked as a duplicate of this bug. ***

Comment 6 David Woodhouse 2007-04-10 19:24:37 UTC
*** Bug 208059 has been marked as a duplicate of this bug. ***

Comment 7 Jeff Johnson 2007-04-10 20:24:03 UTC
The patch hinted in comment #3 is unavaliable through FC cvs or rpm.org repository.

Comment 8 Panu Matilainen 2007-07-17 19:07:12 UTC
AFAICT this has been fixed in F7 quite some time ago.

Jeff, the patch in question is here: http://hg.rpm.org/rpm?cs=a3800aac8945;style=raw


Note You need to log in before you can comment on or make changes to this bug.