Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233132 - initscripts uses /sbin/dmraid
Summary: initscripts uses /sbin/dmraid
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: dmraid
Version: 4.5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Heinz Mauelshagen
QA Contact: Corey Marthaler
URL:
Whiteboard:
Depends On:
Blocks: 234547
TreeView+ depends on / blocked
 
Reported: 2007-03-20 16:10 UTC by Bryn M. Reeves
Modified: 2008-01-28 14:07 UTC (History)
7 users (show)

Fixed In Version: RHBA-2007-0175
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-01 17:15:03 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0175 normal SHIPPED_LIVE dmraid bug fix update 2007-05-01 17:44:38 UTC

Description Bryn M. Reeves 2007-03-20 16:10:30 UTC
Description of problem:
The dmraid binary in RHEL4.5.0 (dmraid-1.0.0.rc14-1_RHEL4_U5) now links to the
dmraid library in /usr/lib:

# ldd /sbin/dmraid
        libdmraid.so.1.0.0.rc14 => /usr/lib/libdmraid.so.1.0.0.rc14 (0x008cd000)
        libdevmapper.so.1.02 => /lib/libdevmapper.so.1.02 (0x0026c000)
        libselinux.so.1 => /lib/libselinux.so.1 (0x0046d000)
        libsepol.so.1 => /lib/libsepol.so.1 (0x00254000)
        libc.so.6 => /lib/tls/libc.so.6 (0x00121000)
        /lib/ld-linux.so.2 (0x00103000)

This means that initscripts need to use the /sbin/dmraid.static version, as is
already the case in the RHEL5 initscripts (initscripts-8.45.15.EL).

Version-Release number of selected component (if applicable):
initscripts-7.93.29.EL

How reproducible:
100%

Steps to Reproduce:
1. Install dmraid on a system with /usr on a separate file system
2. Reboot the machine

  
Actual results:
"/sbin/dmraid: error while loading shared libraries: libdmraid.so.1.0.0.rc14:
can not open shared object file: No such file or directory"

dmraid devices are not configured and must be manually activated by running
dmraid after /usr is mounted.

Expected results:
dmraid runs successfully and configures attached devices if present.

Additional info:
This is a regression from U4 caused by the change in the dmraid package.

Comment 1 Bill Nottingham 2007-03-20 16:27:21 UTC
This would also break third-party customer scripts - I think the simpler
solution is to not change how dmraid is built.

Comment 2 Heinz Mauelshagen 2007-03-21 15:12:04 UTC
I agree unless I overlook an issue with running dmraid.static in initscripts. Size ?

Comment 5 Bryn M. Reeves 2007-03-27 18:25:39 UTC
*** Bug 234204 has been marked as a duplicate of this bug. ***

Comment 20 Red Hat Bugzilla 2007-05-01 17:15:03 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0175.html



Note You need to log in before you can comment on or make changes to this bug.