Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233113 - Build on ppc fails
Summary: Build on ppc fails
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnubg
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 233143
Blocks: FE7Target
TreeView+ depends on / blocked
 
Reported: 2007-03-20 15:10 UTC by Michael Schwendt
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-08 13:29:18 UTC


Attachments (Terms of Use)

Description Michael Schwendt 2007-03-20 15:10:26 UTC
Fedora 5 package is newer than Fedora 6 package.
Fedora 5 package is newer than Fedora 7 package.
But build of package in CVS fails on ppc.
Could also be a bug in gnuplot for ppc.

limb AT jcomserv.net:
    gnubg
      FE5 > FE6 (0:20061119-8.fc5.2 > 0:20061119-7.fc6)
      FE5 > FE7 (0:20061119-8.fc5.2 > 0:20061119-7.fc7)

[...]

	  for f in gnubg.info gnubg.info-[0-9] gnubg.info-[0-9][0-9] gnubg.i[0-9]
gnubg.i[0-9][0-9]; do \
	    if test -f $f; then mv $f $backupdir; restore=mv; else :; fi; \
	  done; \
	else :; fi && \
	cd "$am__cwd"; \
	if /bin/sh /builddir/build/BUILD/gnubg/missing --run makeinfo   -I . \
	 -o gnubg.info gnubg.texi; \
	then \
	  rc=0; \
	  cd .; \
	else \
	  rc=$?; \
	  cd . && \
	  $restore $backupdir/* `echo "./gnubg.info" | sed 's|[^/]*$||'`; \
	fi; \
	rm -rf $backupdir; exit $rc
if [ -n "gnuplot" ]; then \
	gnuplot annealing.gp && \
	tr -d '\f' < anneal.txt > ./annealing.txt; fi
/bin/sh: line 2:   400 Segmentation fault      gnuplot annealing.gp
make[2]: *** [annealing.eps] Error 139
make[2]: Leaving directory `/builddir/build/BUILD/gnubg/doc'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/builddir/build/BUILD/gnubg'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.79732 (%build)

Comment 1 David Woodhouse 2007-03-20 16:13:53 UTC
It builds for me on FC6. Rawhide dies thus:

RPM build errors:
    user dwmw2 does not exist - using root
    group dwmw2 does not exist - using root
    user dwmw2 does not exist - using root
    group dwmw2 does not exist - using root
    user dwmw2 does not exist - using root
    group dwmw2 does not exist - using root
    user dwmw2 does not exist - using root
    group dwmw2 does not exist - using root
    user dwmw2 does not exist - using root
    group dwmw2 does not exist - using root
    File not found: /var/tmp/gnubg-20061119-8-root-root/usr/share/gnubg/textures.txt
    File not found: /var/tmp/gnubg-20061119-8-root-root/usr/share/gnubg/textures


Comment 2 Gwyn Ciesla 2007-03-20 16:23:58 UTC
It builds fine for me in FC-6 also, but dies that way (#1) in mock.  I've not
made any changes since this was released.  It must be something gnubg depends on
causing this, since in installed releases, the textures files are present.

I'll go through the source and see what I can find, my mock log doesn't look
promising so far. . .

Comment 4 Gwyn Ciesla 2007-03-20 16:54:29 UTC
That definately looks like a gnuplot bug.  I'll file it.  

Now, I still need to figure out the textures issue.

Comment 5 David Woodhouse 2007-03-20 17:05:16 UTC
http://david.woodhou.se/gnubg-build.log

Comment 6 Gwyn Ciesla 2007-03-20 17:09:03 UTC
(In reply to comment #5)
> http://david.woodhou.se/gnubg-build.log

How did you manage this? Any changes from vanilla patched devel?

Comment 7 David Woodhouse 2007-03-20 17:28:50 UTC
It's not quite up to date rawhide. I made the SRPM from CVS, then tried
'rpmbuild --target ppc --rebuild ...'. And watched it fail.

Comment 8 Gwyn Ciesla 2007-03-20 17:32:18 UTC
So you're cross-compiling?  Michael, is your host native ppc?

Comment 9 David Woodhouse 2007-03-20 17:46:26 UTC
Not crosscompiling. It's a native build on ppc64 (Actually an IBM pSeries POWER5
machine). Fairly similar to the machine in the build system, I think.

Comment 10 Gwyn Ciesla 2007-03-20 17:53:57 UTC
IOC.  I've nearly got a version done to correct the textures issue.  I'll get it
into CVS and see where the gnuplot bug leads.

Comment 11 Michael Schwendt 2007-03-20 18:02:07 UTC
ppc2.fedora.redhat.com is native powerpc, yes.

[...]

Build for FC-6 succeeded:
http://buildsys.fedoraproject.org/build-status/job.psp?uid=29844


Comment 12 Gwyn Ciesla 2007-03-20 18:48:22 UTC
Committed new fix for textures, but I still get the gnuplot failure.
http://buildsys.fedoraproject.org/logs/fedora-development-extras/29934-gnubg-20061119-9.fc7/

Comment 13 Gwyn Ciesla 2007-04-04 18:56:23 UTC
Still fails on devel, succeeds on FC6.  SAme for all arches.  Updated gnuplot bug.

Comment 14 Gwyn Ciesla 2007-04-17 12:31:10 UTC
Updated FC6 local build with gnuplot-4.0.0-18.fc7.i386.rpm installed works.

Since today is the Freeze, I'll resume testing after release, I suppose.

Comment 15 Gwyn Ciesla 2007-05-08 13:29:18 UTC
Built on all archs, closing.  In communication with rel-eng.


Note You need to log in before you can comment on or make changes to this bug.