Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233089 - LILO hangs after kernel upgrading to 2.6.19/2.6.20
Summary: LILO hangs after kernel upgrading to 2.6.19/2.6.20
Alias: None
Product: Fedora
Classification: Fedora
Component: lilo
Version: 5
Hardware: i686
OS: Linux
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Brock Organ
Whiteboard: bzcl34nup
Depends On:
TreeView+ depends on / blocked
Reported: 2007-03-20 13:59 UTC by 260795
Modified: 2008-04-10 18:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2008-04-10 18:49:48 UTC

Attachments (Terms of Use)
Lilo log, 2.6.20 kernel (deleted)
2007-03-20 14:02 UTC, 260795
no flags Details
Lilo log, 2.6.15 kernel (deleted)
2007-03-20 14:03 UTC, 260795
no flags Details
Lilo configuration file (deleted)
2007-03-20 14:12 UTC, 260795
no flags Details

Description 260795 2007-03-20 13:59:10 UTC
Description of problem: after upgrading to kernel 2.6.19 or 2.6.20 lilo stop 
working, consuming 100% cpu time whenever called to update the current 
configuration. Works with the stock 2.6.15 kernel.

Version-Release number of selected component (if applicable): LILO version 21.4-

How reproducible: reproducible.

Steps to Reproduce: run lilo with one of the kernels above
Actual results: lilo hangs.

Expected results: usual update of the current configuration.

Additional info: attached a lilo -v 3 log with the 2.6.15 kernel and the 2.6.20 
kernel. Top show a 100% CPU usage, reporting that it is almost only system CPU 

Comment 1 260795 2007-03-20 14:02:12 UTC
Created attachment 150480 [details]
Lilo log, 2.6.20 kernel

Comment 2 260795 2007-03-20 14:03:16 UTC
Created attachment 150481 [details]
Lilo log, 2.6.15 kernel

Comment 3 260795 2007-03-20 14:12:54 UTC
Created attachment 150482 [details]
Lilo configuration file

I already tried almost any relevant lilo option to work around the problem,
with no result.

Comment 4 Chuck Ebbert 2007-03-20 20:45:48 UTC
Can you get output from alt-sysrq-p when this happens?

Or, this will show state too:
   echo "p" >/proc/sysrq-trigger

Do that several times and post the output.

Comment 5 260795 2007-03-21 08:31:17 UTC
Tried it, both with lilo hanging and without lilo running. On the console, the 
dmesg buffer and in the /var/log/messages file the following message appears:

SysRq : Show Regs

Nothing else. I tried quickly repeating the echo command dozens of times, even 
after leaving lilo haging for quite a long time. The message above just get 
repeated over and over. Ma be I have to enable something to get the requested 

I also tried leaving lilo running all night long, just to see if some long 
timeout gets triggered, with no result. Lilo keeps consuming 100% system CPU 
and does nothing else.

Comment 6 Bug Zapper 2008-04-04 06:35:57 UTC
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:

We will be following the process here: to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out

Comment 7 260795 2008-04-07 06:58:10 UTC
Upgraded to grub since then, so I'm no longer able to supply informations for
this problem.

Comment 8 John Poelstra 2008-04-10 18:49:48 UTC
thanks for the update

Note You need to log in before you can comment on or make changes to this bug.