Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233077 - hddtemp on SATA drives fails on 2.6.20-1.2300.fc5
Summary: hddtemp on SATA drives fails on 2.6.20-1.2300.fc5
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: hddtemp
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ville Skyttä
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-20 12:20 UTC by Russ Price
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: 0.3-0.11.beta15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-21 21:03:14 UTC


Attachments (Terms of Use)

Description Russ Price 2007-03-20 12:20:28 UTC
Description of problem:
Attempting to run hddtemp with a SATA drive produces results like this:

/dev/sda: ATA SAMSUNG SP2504C: S.M.A.R.T. not available

Version-Release number of selected component (if applicable):

2.6.20-1.2300.fc5

How reproducible:

Always

Steps to Reproduce:
1. Boot 2.6.20-1.2300.fc5
2. Run hddtemp on a SATA drive.
  
Actual results:

/dev/sda: ATA SAMSUNG SP2504C: S.M.A.R.T. not available

Expected results:

/dev/sda: ATA SAMSUNG SP2504C: 40°C

Additional info:

Attempting to force the SATA drive type in /etc/sysconfig/hddtemp has no effect.

smartctl -d ata -a /dev/sda
produces a S.M.A.R.T. report

It is possible that the bug is in hddtemp, but the problem only began with the
new kernel.

Comment 1 Chuck Ebbert 2007-03-20 14:10:35 UTC
What version of hddtemp do you have?


Comment 2 Russ Price 2007-03-20 22:19:44 UTC
hddtemp-0.3-0.8.beta15.fc5 is installed on this system.

Comment 3 Chuck Ebbert 2007-03-20 22:37:05 UTC
This is due to a bug in hddtemp.

It needs this patch:

http://lkml.org/lkml/2006/12/19/131

I submitted it to the hddtemp bug reporting system.


Comment 4 Kevin Kofler 2007-03-21 18:08:16 UTC
This also affects PATA drives on Promise SATA/PATA controllers with a kernel 
fixed for bug 232600, such as kernel-2.6.20-1.2932.fc6. (They also use libata, 
so I assume it's the same problem.) Is a fixed hddtemp forthcoming?

Comment 5 Kevin Kofler 2007-03-21 19:51:44 UTC
Adding hddtemp maintainer to CC. To sum up, hddtemp needs an update/patch to 
work with kernel >=2.6.20's libata, for all of FC5, FC6 and devel. Please see 
the previous comments for details. The bug should also be reassigned to 
hddtemp, but as I'm not the submitter nor in fedorabugs, I can't do that.

Comment 6 Kevin Kofler 2007-03-21 20:03:48 UTC
Looking at the CVS, it turns out this is already fixed in devel (first reported 
as #221100), and has been fixed in CVS for FC6 and FC5 a few minutes ago. 
Thanks Ville. So I guess this can be closed now (or once the builds get 
pushed).

Comment 7 Ville Skyttä 2007-03-21 21:03:14 UTC
Yep, Chuck was kind enough to ping me about this.  I had been running the
patched version locally ever since bug 221100 was fixed and was thus not bitten
by forgetting to push the builds for <= FC6 when they got a 2.6.20 kernel, sorry
about that.  Builds are done now, and will be in the next push.


Note You need to log in before you can comment on or make changes to this bug.