Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233065 - FutureFeature: Install Fedora core 5 / 6 (improving for the guide)
Summary: FutureFeature: Install Fedora core 5 / 6 (improving for the guide)
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-20 08:49 UTC by Huang Yu
Modified: 2008-02-20 23:46 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-02-20 23:46:26 UTC


Attachments (Terms of Use)
Chinese tradition (deleted)
2007-03-20 08:49 UTC, Huang Yu
no flags Details

Description Huang Yu 2007-03-20 08:49:54 UTC
Description of problem:

When we install Fedora core 5/6, the last step is to decide whether or not 
selecting single software(s) by oneself.

  Now the problem is that if the free space of the hard disk partition
(/ or /usr) is not enough, then the next installint step will be forced to
stop. And then we must restart the computer and All we have done lost.

  I propose:
  1. Check the free space of user before real installation.
  2. Display the size of the single software when users select it, and
     the total size of the softwares having been selected.

Thanks you all,
By quxtilf,
From Guang Zhou, China.

Comment 1 Huang Yu 2007-03-20 08:49:54 UTC
Created attachment 150466 [details]
Chinese tradition

Comment 2 Chris Lumens 2008-02-16 18:12:25 UTC
anaconda in later releases will allow you to go back and modify your package
selections if we discover you do not have enough space to install everything. 
For adding the size information to the dialog, I'm reassigning this to pirut
(the software component we use for that screen).

Comment 3 Jeremy Katz 2008-02-20 23:46:26 UTC
Showing the size would require calculating dependencies at run-time which is
pretty expensive and leads to a poor (laggy) UI


Note You need to log in before you can comment on or make changes to this bug.