Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233035 - Erroneous error message (use asknetwork) on text based iSCSI dialog
Summary: Erroneous error message (use asknetwork) on text based iSCSI dialog
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-19 23:27 UTC by Robert Love
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-02 22:24:37 UTC


Attachments (Terms of Use)

Description Robert Love 2007-03-19 23:27:15 UTC
Description of problem:
A dialog in the text based installation provides an incorrect error message
referring to a non-existant boot option.

Version-Release number of selected component (if applicable):
anaconda-11.1.2.34-2.i386.rpm

How reproducible:
Always.

Steps to Reproduce:
In a text based install follow the following dialogs.

“Partitioning Type” dialog, press F2 to “Add drive”

“Advanced Storage Options” dialog presents user with “Add iSCSI target” and the
user selects “OK”.

“Error” dialog instructs the user to boot with ‘linux asknetwork’.

The problem is that there is no "asknetwork" boot option. It's not documented in
command-line.txt nor in any of the HTML documentation.

  
Actual results:


Expected results:
The error dialog should recommend an actual boot option.

Additional info:

Comment 1 Chris Lumens 2007-03-20 14:13:28 UTC
There actually is an asknetwork boot option.  It's just not documented.  I'll
fix this on head.  If you require this in a RHEL5 update release, we'll need to
raise it through the proper channels and we can look at adding documentation.

Comment 2 Robert Love 2007-03-20 17:11:03 UTC
(In reply to comment #1)
> There actually is an asknetwork boot option.  It's just not documented.  I'll
> fix this on head.  If you require this in a RHEL5 update release, we'll need to
> raise it through the proper channels and we can look at adding documentation.

I think it should be documented in the next update, otherwise users won't know
how to use it. However, I've tried to use "asknetwork" and nothing seems to
happen. Since I don't know the format of the command I also tried
"asknetwork=1". I'm expecting the standard "What network interface would you
like to configure / DCHP vs. static / etc..." dialog to display early in the
install. If my expectation is incorrect please correct me.

I'm not sure if this was the right place to look or not, but I extracted the
anaconda RPM and then did a "grep -Hrni asknetwork .". I didn't see any code
related to this boot option. 

Comment 3 David Cantrell 2007-04-02 22:24:17 UTC
The option is in the stage 1 loader:

loader.c:608:        else if (!strcasecmp(argv[i], "asknetwork"))

There are no options for the asknetwork boot parameter.  It's simply
'asknetwork' and it instructs the loader to ask you to configure your network
interface during stage 1 regardless of your installation method.

The command-line.txt file has been updated in rawhide.  Please contact your TAM
or RH support provider to raise the issue as a RHEL-5 bug so that we can examine
it for inclusion in an update release.


Note You need to log in before you can comment on or make changes to this bug.