Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233031 - primary leg failure during GFS I/O causes I/O error and then GFS withdraw
Summary: primary leg failure during GFS I/O causes I/O error and then GFS withdraw
Keywords:
Status: CLOSED DUPLICATE of bug 232711
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: cmirror
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Earl Brassow
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On: 232711
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-19 23:05 UTC by Corey Marthaler
Modified: 2010-01-12 02:02 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-12 17:49:44 UTC


Attachments (Terms of Use)

Description Corey Marthaler 2007-03-19 23:05:52 UTC
Description of problem:
Simple case, two cmirrors, gfs on top of both, gfs I/O ruuning to both
(xdoio/xiogen). Then failed the primary legs, caused one of the gfs filesystems
to withdraw due to an I/O error. Note, the down conversion did appear to work
properly.


[root@link-08 ~]# lvs -a -o +devices
  LV                 VG         Attr   LSize  Origin Snap%  Move Log         
Copy%  Devices                       
  LogVol00           VolGroup00 -wi-ao 72.38G                                  
     /dev/hda2(0)                  
  LogVol01           VolGroup00 -wi-ao  1.94G                                  
     /dev/hda2(2316)               
  mirror1            cool       mwi-ao  4.00G                    mirror1_mlog
100.00 mirror1_mimage_0(0),mirror1_mimage_1(0)
  [mirror1_mimage_0] cool       iwi-ao  4.00G                                  
     /dev/sdh1(0)                  
  [mirror1_mimage_1] cool       iwi-ao  4.00G                                  
     /dev/sda1(0)                  
  [mirror1_mlog]     cool       lwi-ao  4.00M                                  
     /dev/sdg1(0)                  
  mirror2            cool       mwi-ao  4.00G                    mirror2_mlog
100.00 mirror2_mimage_0(0),mirror2_mimage_1(0)
  [mirror2_mimage_0] cool       iwi-ao  4.00G                                  
     /dev/sdh1(1024)               
  [mirror2_mimage_1] cool       iwi-ao  4.00G                                  
     /dev/sdb1(0)                  
  [mirror2_mlog]     cool       lwi-ao  4.00M                                  
     /dev/sda1(1024)               


SCSI error : <3 0 1 1> return code = 0x10000
end_request: I/O error, dev sdh, sector 12509761
SCSI error : <3 0 1 1> return code = 0x10000
end_request: I/O error, dev sdh, sector 16065
SCSI error : <3 0 1 1> return code = 0x10000
end_request: I/O error, dev sdh, sector 16065
GFS: fsid=LINK_128:gfs2.1: fatal: I/O error
GFS: fsid=LINK_128:gfs2.1:   block = 513088
GFS: fsid=LINK_128:gfs2.1:   function = gfs_logbh_wait
GFS: fsid=LINK_128:gfs2.1:   file =
/builddir/build/BUILD/gfs-kernel-2.6.9-71/smp/src/gfs/dio.c, line = 923
GFS: fsid=LINK_128:gfs2.1:   time = 1174326896
GFS: fsid=LINK_128:gfs2.1: about to withdraw from the cluster
GFS: fsid=LINK_128:gfs2.1: waiting for outstanding I/O
GFS: fsid=LINK_128:gfs2.1: telling LM to withdraw
Mar 19 12:54:56 link-08 kernel: SCSI error : <3 0 1 1> return code = 0x10000
Mar 19 12:54:56 link-08 kernel: end_request: I/O error, dev sdh, sector 12509761
Mar 19 12:54:56 link-08 kernel: SCSI error : <3 0 1 1> return code = 0x10000
Mar 19 12:54:56 link-08 kernel: end_request: I/O error, dev sdh, sector 16065
Mar 19 12:54:56 link-08 kernel: SCSI error : <3 0 1 1> return code = 0x10000
Mar 19 12:54:56 link-08 kernel: end_request: I/O error, dev sdh, sector 16065
Mar 19 12:54:56 link-08 kernel: GFS: fsid=LINK_128:gfs2.1: fatal: I/O error
Mar 19 12:54:56 link-08 kernel: GFS: fsid=LINK_128:gfs2.1:   block = 513088
Mar 19 12:54:56 link-08 kernel: GFS: fsid=LINK_128:gfs2.1:   function =
gfs_logbh_wait
Mar 19 12:54:56 link-08 kernel: GFS: fsid=LINK_128:gfs2.1:   file =
/builddir/build/BUILD/gfs-kernel-2.6.9-71/smp/src/gfs/dio.c, line = 923
Mar 19 12:54:56 link-08 kernel: GFS: fsid=LINK_128:gfs2.1:   time = 1174326896
Mar 19 12:54:56 link-08 kernel: GFS: fsid=LINK_128:gfs2.1: about to withdraw
from the cluster
Mar 19 12:54:56 link-08 kernel: GFS: fsid=LINK_128:gfs2.1: waiting for
outstanding I/O
Mar 19 12:54:56 link-08 kernel: GFS: fsid=LINK_128:gfs2.1: telling LM to withdraw
Mar 19 12:54:56 link-08 lvm[4639]: No longer monitoring mirror device
cool-mirror1 for events
lock_dlm: withdraw abandoned memory
GFS: fsid=LINK_128:gfs2.1: withdrawn
Mar 19 12:55:05 link-08 kernel: lock_dlm: withdraw abandoned memory
Mar 19 12:55:05 link-08 kernel: GFS: fsid=LINK_128:gfs2.1: withdrawn
Mar 19 12:55:06 link-08 kernel: dm-cmirror: Removing SSsrG5HS (1)


[root@link-08 ~]# lvs -a -o +devices
  /dev/sdh1: read failed after 0 of 2048 at 0: Input/output error
  LV       VG         Attr   LSize  Origin Snap%  Move Log Copy%  Devices
  LogVol00 VolGroup00 -wi-ao 72.38G                               /dev/hda2(0)
  LogVol01 VolGroup00 -wi-ao  1.94G                               /dev/hda2(2316)
  mirror1  cool       -wi-ao  4.00G                               /dev/sda1(0)
  mirror2  cool       -wi-ao  4.00G                               /dev/sdb1(0)


Version-Release number of selected component (if applicable):
2.6.9-50.ELsmp
cmirror-kernel-2.6.9-25.0

Comment 1 Jonathan Earl Brassow 2007-04-05 15:04:18 UTC
In order to have the down conversion happen, bug 232711 will have to be fixed.



Comment 2 Corey Marthaler 2007-04-12 17:49:44 UTC
This was most likely a result of a non sync'ed primary leg being failed, thus
duping this bug to 232711.

*** This bug has been marked as a duplicate of 232711 ***


Note You need to log in before you can comment on or make changes to this bug.