Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232997 - xsane segfault while scanning
Summary: xsane segfault while scanning
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xsane
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-19 20:11 UTC by Karl MacMillan
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-26 06:25:44 UTC


Attachments (Terms of Use)

Description Karl MacMillan 2007-03-19 20:11:33 UTC
Description of problem:

Current xsane always segfaults when scanning (acquire preview works fine). This
is with an epson perfection 1240 over usb. Downgrading to the FC6 version fixes
the problem.

[kmacmill@localhost ~]$ rpm -qa | grep xsane
xsane-gimp-0.993-1.fc7
xsane-0.993-1.fc7
xsane-debuginfo-0.993-1.fc7

Core was generated by `xsane'.
Program terminated with signal 11, Segmentation fault.
#0  0x473d3ca0 in strncpy () from /lib/libc.so.6
(gdb) bt
#0  0x473d3ca0 in strncpy () from /lib/libc.so.6
#1  0x080b04ad in xsane_start_scan () at xsane-scan.c:1772
#2  0x080b0f02 in xsane_scan_dialog (data=0x0) at xsane-scan.c:2125
#3  0x080b7932 in xsane_scan_callback () at xsane.c:3942
#4  0x479470f9 in g_cclosure_marshal_VOID__VOID () from /lib/libgobject-2.0.so.0
#5  0x47939d9b in g_closure_invoke () from /lib/libgobject-2.0.so.0
#6  0x4794a433 in read () from /lib/libgobject-2.0.so.0
#7  0x4794b957 in g_signal_emit_valist () from /lib/libgobject-2.0.so.0
#8  0x4794bb19 in g_signal_emit () from /lib/libgobject-2.0.so.0
#9  0x4db36cd3 in gtk_button_clicked () from /usr/lib/libgtk-x11-2.0.so.0
#10 0x4db3891e in read () from /usr/lib/libgtk-x11-2.0.so.0
#11 0x479470f9 in g_cclosure_marshal_VOID__VOID () from /lib/libgobject-2.0.so.0
#12 0x47938589 in read () from /lib/libgobject-2.0.so.0
#13 0x47939d9b in g_closure_invoke () from /lib/libgobject-2.0.so.0
#14 0x4794a8ca in read () from /lib/libgobject-2.0.so.0
#15 0x4794b957 in g_signal_emit_valist () from /lib/libgobject-2.0.so.0
#16 0x4794bb19 in g_signal_emit () from /lib/libgobject-2.0.so.0
#17 0x4db36d63 in gtk_button_released () from /usr/lib/libgtk-x11-2.0.so.0
#18 0x4db36dc1 in read () from /usr/lib/libgtk-x11-2.0.so.0
#19 0x4dc07bb0 in read () from /usr/lib/libgtk-x11-2.0.so.0
#20 0x47938589 in read () from /lib/libgobject-2.0.so.0
#21 0x47939d9b in g_closure_invoke () from /lib/libgobject-2.0.so.0
#22 0x4794aa83 in read () from /lib/libgobject-2.0.so.0
#23 0x4794b71f in g_signal_emit_valist () from /lib/libgobject-2.0.so.0
#24 0x4794bb19 in g_signal_emit () from /lib/libgobject-2.0.so.0
#25 0x4dd1c838 in read () from /usr/lib/libgtk-x11-2.0.so.0
#26 0x4dc00f83 in gtk_propagate_event () from /usr/lib/libgtk-x11-2.0.so.0
#27 0x4dc02187 in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
#28 0x4deb511a in read () from /usr/lib/libgdk-x11-2.0.so.0
#29 0x477c1442 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#30 0x477c441f in read () from /lib/libglib-2.0.so.0
#31 0x477c47c9 in g_main_loop_run () from /lib/libglib-2.0.so.0
#32 0x4dc02604 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#33 0x080c10d1 in xsane_interface (argc=1, argv=0xbf927844) at xsane.c:6036
#34 0x080c2269 in main (argc=1, argv=0xbf927844) at xsane.c:6233
#35 0x4737cec0 in __libc_start_main () from /lib/libc.so.6
#36 0x0804df81 in _start ()

Comment 1 Tom London 2007-03-22 15:13:09 UTC
Get a similar one.....

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1209010496 (LWP 4560)]
0x4ed57b20 in strncpy () from /lib/libc.so.6
(gdb) where
#0  0x4ed57b20 in strncpy () from /lib/libc.so.6
#1  0x080b04ad in read ()
#2  0x080b0f02 in read ()
#3  0x080b7932 in read ()
#4  0x4f0680f9 in g_cclosure_marshal_VOID__VOID ()
   from /lib/libgobject-2.0.so.0
#5  0x4f05ad9b in g_closure_invoke () from /lib/libgobject-2.0.so.0
#6  0x4f06b433 in read () from /lib/libgobject-2.0.so.0
#7  0x4f06c957 in g_signal_emit_valist () from /lib/libgobject-2.0.so.0
#8  0x4f06cb19 in g_signal_emit () from /lib/libgobject-2.0.so.0
#9  0x41a75d03 in gtk_button_clicked () from /usr/lib/libgtk-x11-2.0.so.0
#10 0x41a7794e in read () from /usr/lib/libgtk-x11-2.0.so.0
#11 0x4f0680f9 in g_cclosure_marshal_VOID__VOID ()
   from /lib/libgobject-2.0.so.0
#12 0x4f059589 in read () from /lib/libgobject-2.0.so.0
#13 0x4f05ad9b in g_closure_invoke () from /lib/libgobject-2.0.so.0
#14 0x4f06b8ca in read () from /lib/libgobject-2.0.so.0
#15 0x4f06c957 in g_signal_emit_valist () from /lib/libgobject-2.0.so.0
#16 0x4f06cb19 in g_signal_emit () from /lib/libgobject-2.0.so.0
#17 0x41a75d93 in gtk_button_released () from /usr/lib/libgtk-x11-2.0.so.0
#18 0x41a75df1 in read () from /usr/lib/libgtk-x11-2.0.so.0
#19 0x41b46c40 in read () from /usr/lib/libgtk-x11-2.0.so.0
#20 0x4f059589 in read () from /lib/libgobject-2.0.so.0
---Type <return> to continue, or q <return> to quit---
#21 0x4f05ad9b in g_closure_invoke () from /lib/libgobject-2.0.so.0
#22 0x4f06ba83 in read () from /lib/libgobject-2.0.so.0
#23 0x4f06c71f in g_signal_emit_valist () from /lib/libgobject-2.0.so.0
#24 0x4f06cb19 in g_signal_emit () from /lib/libgobject-2.0.so.0
#25 0x41c5bb48 in read () from /usr/lib/libgtk-x11-2.0.so.0
#26 0x41b40003 in gtk_propagate_event () from /usr/lib/libgtk-x11-2.0.so.0
#27 0x41b41207 in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
#28 0x4181015a in read () from /usr/lib/libgdk-x11-2.0.so.0
#29 0x4eecb622 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#30 0x4eece5ff in read () from /lib/libglib-2.0.so.0
#31 0x4eece9a9 in g_main_loop_run () from /lib/libglib-2.0.so.0
#32 0x41b41684 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#33 0x080c10d1 in read ()
#34 0x080c2269 in read ()
#35 0x4ecffec0 in __libc_start_main () from /lib/libc.so.6
#36 0x0804df81 in read ()
(gdb) 


Comment 2 Nils Philippsen 2007-04-25 07:44:51 UTC
I've built 0.994, can you please check whether the problem still exists?

Comment 3 Karl MacMillan 2007-04-25 14:19:29 UTC
I no longer have the correct setup to try and reproduce.

Comment 4 Nils Philippsen 2007-04-25 15:06:07 UTC
Tom, can you please give it a try?

Comment 5 Tom London 2007-04-25 16:06:20 UTC
OK.  Will do this when I get home tonight.

Comment 6 Tom London 2007-04-26 02:33:15 UTC
xsane-0.994-2.fc7 works for me.

Close?

Comment 7 Nils Philippsen 2007-04-26 06:25:44 UTC
Yeah, close.


Note You need to log in before you can comment on or make changes to this bug.