Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232987 - horde 3.1.4-1.fc6 creates infinite redirect loop on login
Summary: horde 3.1.4-1.fc6 creates infinite redirect loop on login
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: horde
Version: 6
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Brandon Holbrook
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-19 19:26 UTC by Håvard Wigtil
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-21 02:36:36 UTC


Attachments (Terms of Use)

Description Håvard Wigtil 2007-03-19 19:26:17 UTC
Description of problem:
After upgrading to horde 3.1.4-1.fc6, I get a redirect loop on login.
Firefox comes up with this message after a little while:
---------------------------------------------------------------------
The page isn't redirecting properly
Firefox has detected that the server is redirecting the request for this address
in a way that will never complete.
---------------------------------------------------------------------

And in my logs I get this:
84.48.62.251 - - [19/Mar/2007:20:12:10 +0100] "GET /horde/ HTTP/1.1" 302 26
84.48.62.251 - - [19/Mar/2007:20:12:10 +0100] "GET /horde/index.php/login.php
HTTP/1.1" 302 26
84.48.62.251 - - [19/Mar/2007:20:12:10 +0100] "GET /horde/index.php/login.php
HTTP/1.1" 302 26
(the last line repeated 18 times)

Downgrading to 3.1.3-11 fixes the problem for me.

Version-Release number of selected component (if applicable):
horde 3.1.4-1.fc6

How reproducible:
Always

Comment 1 Brandon Holbrook 2007-03-20 05:59:22 UTC
It seems that horde introduced some new webroot-detection mechanisms to 'more
intelligently' generate URLs back to itself.  This autodetection is bombing on
our file structure (config files in /etc instead of under /usr/share/horde).  I
have just recently found a few other issues I believe to be caused by this
autodetection, and I believe your problem falls under this category too.

In /etc/horde/registry.php in the 'horde' section, try changing the 'webroot'
setting to '/horde' instead of _detect_webroot().  I have already included this
fix in rawhide, but if this change resolves your issues too, I will push an
update for FC6 as well.

Comment 2 Håvard Wigtil 2007-03-20 21:04:49 UTC
Changing webroot to '/horde' fixes this problem for me, thanks!

Comment 3 Brandon Holbrook 2007-03-21 02:36:36 UTC
webroot is now hard-coded to '/horde' in horde-3.1.4-2.fc[567]


Note You need to log in before you can comment on or make changes to this bug.