Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232964 - Switching sound track kills sound
Summary: Switching sound track kills sound
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gstreamer-plugins-base
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-19 18:06 UTC by Pete Zaitcev
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-17 10:01:05 UTC


Attachments (Terms of Use)
GST_DEBUG=*:2 totem dvd://2 (deleted)
2007-03-19 18:34 UTC, Pete Zaitcev
no flags Details

Description Pete Zaitcev 2007-03-19 18:06:50 UTC
Description of problem:

While playing a DVD (unencrypted) with multiply sound tracks, switching
between tracks kills the sound.

Version-Release number of selected component (if applicable):

totem-2.18.0-1.fc7

How reproducible:

Seems like 100%

Steps to Reproduce:
1. Play "Excel Saga" volume 1 (any ADV release will work, they
   are all unencrypted).
2. Switch from English to Japanese.
3. Sound is dead.
  
Actual results:

Sound is dead.

Expected results:

Japanese sound track.

Additional info:

The switch is done with Sound->Languages->Japanese.

This function used to work in FC-5. Sorry, I didn't test any newer releases.

Comment 1 Bastien Nocera 2007-03-19 18:27:13 UTC
How did you launch totem? Do you see any errors on the command-line?

If not, please attach the output of "GST_DEBUG=*:2 totem" and reproduce the problem.

Comment 2 Bastien Nocera 2007-03-19 18:31:56 UTC
In bug 232971, you don't mention having the gstreamer-plugins-ugly package
installed, which means that AC3 decoding is done (probably badly) through
ffmpeg. Could you try and install gstreamer-plugins-ugly (from livna as well),
and let me know whether it fixes it?

(The 2 audio tracks are probably in different formats, one in PCM audio, the
other in AC3).

Comment 3 Pete Zaitcev 2007-03-19 18:34:52 UTC
Created attachment 150406 [details]
GST_DEBUG=*:2 totem dvd://2

This is the result of:
 GST_DEBUG=*:2 totem dvd://2 >totem.run 2>&1 </dev/null
Nothing obvious has changed in the output when the sound died.
Exactly the same thing kept scrolling before and after.

Comment 4 Pete Zaitcev 2007-03-19 19:38:17 UTC
Looks like gstreamer-plugins-ugly is installed, and its architecture
is compatible:

[root@niphredil zaitcev]# rpm -qa --queryformat
"%{name}-%{version}-%{release}.%{arch}\\n" | grep gst
gstreamer-plugins-base-0.10.12-2.fc7.i386
gstreamer-plugins-ugly-0.10.5-1.lvn7.x86_64
gstreamer-0.10.12-1.fc7.i386
gstreamer-tools-0.10.12-1.fc7.x86_64
gstreamer-0.10.12-1.fc7.x86_64
gstreamer-plugins-base-0.10.12-2.fc7.x86_64
gstreamer-ffmpeg-0.10.2-1.lvn7.x86_64
gstreamer-plugins-good-0.10.5-5.fc7.x86_64
[root@niphredil zaitcev]# rpm -qa --queryformat
"%{name}-%{version}-%{release}.%{arch}\\n" | grep totem
totem-2.18.0-1.fc7.x86_64
totem-plparser-2.18.0-1.fc7.x86_64
[root@niphredil zaitcev]# 


Comment 5 Pete Zaitcev 2007-03-19 19:42:36 UTC
Japanese often ship DVDs with PCM audio, and actually I have a few.
But this one is an R1. I ran mplayer -v dvd://2 and it printed this:

DVD successfully opened.
audio stream: 0 format: ac3 (stereo) language: en aid: 128.
audio stream: 1 format: ac3 (stereo) language: ja aid: 129.
audio stream: 2 format: ac3 (stereo) language: en aid: 130.
audio stream: 3 format: ac3 (stereo) language: ja aid: 131.
number of audio channels on disk: 4.

Totem correctly shows 4 tracks in its menu, only it names them
"English", "Japanese", "en #2", "ja #2".


Comment 6 Bastien Nocera 2007-04-17 10:01:05 UTC
Known upstream problem.
See http://bugzilla.gnome.org/show_bug.cgi?id=344706


Note You need to log in before you can comment on or make changes to this bug.