Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232936 - Partitions not being created in raid install
Summary: Partitions not being created in raid install
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Chris Lumens
QA Contact:
: 232502 (view as bug list)
Depends On:
Blocks: FC7Blocker
TreeView+ depends on / blocked
Reported: 2007-03-19 15:32 UTC by Orion Poplawski
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2007-04-23 20:14:47 UTC

Attachments (Terms of Use)
anaconda dump (deleted)
2007-03-19 15:32 UTC, Orion Poplawski
no flags Details

Description Orion Poplawski 2007-03-19 15:32:09 UTC
I'm trying with the following partition setup:

part raid.1 --size=128 --ondisk=sda
part raid.2 --size=6000 --grow --ondisk=sda
part raid.3 --size=6000 --grow --ondisk=sdc
part raid.4 --size=128 --ondisk=sdb
part raid.5 --size=6000 --grow --ondisk=sdb
part raid.6 --size=6000 --grow --ondisk=sdd
raid /boot --fstype ext3 --level=RAID1 --device=md0 raid.1 raid.4
raid pv.1 --level=RAID1 --device=md1 raid.2 raid.3 raid.5 raid.6
volgroup rootvg pv.1

but no partitions are being created.  It fails on:

12:25:47 INFO    : moving (1) to step partitionobjinit
12:25:47 INFO    : no initiator set
12:25:47 INFO    : no /tmp/fcpconfig; not configuring zfcp
12:25:48 INFO    : moving (1) to step autopartitionexecute
12:25:50 INFO    : moving (1) to step partitiondone
12:25:50 INFO    : moving (1) to step bootloadersetup
12:25:50 WARNING : MBR not suitable as boot device; installing to partition
12:25:50 INFO    : moving (1) to step networkdevicecheck
12:25:50 INFO    : moving (1) to step reposetup
12:25:50 INFO    : added repository extras with with source URL
12:25:50 INFO    : added repository CoRA with with source URL
12:25:55 INFO    : moving (1) to step basepkgsel
12:25:58 DEBUG   : no package matching gv
12:26:22 DEBUG   : no package matching gv
12:26:26 DEBUG   : no such package isdn4k-utils
12:26:26 INFO    : moving (1) to step postselection
12:26:26 DEBUG   : no kernel-smp package
12:26:26 INFO    : selected kernel package for kernel
12:30:33 INFO    : moving (1) to step install
12:30:33 INFO    : moving (1) to step enablefilesystems
12:30:34 INFO    : going to run: ['mdadm', '--create', '/dev/md1', '--run',
'--chunk=256', '--level=0', '--raid-devices=4', '/dev/sda2', '/dev/sdb2',
'/dev/sdc1', '/dev/sdd1']
12:30:34 CRITICAL: Traceback (most recent call first):
  File "/usr/lib/anaconda/", line 277, in pvcreate
    raise PVCreateError(node)
  File "/usr/lib/anaconda/", line 2263, in setupDevice
  File "/usr/lib/anaconda/", line 1632, in createLogicalVolumes
  File "/usr/lib/anaconda/", line 149, in turnOnFilesystems
  File "/usr/lib/anaconda/", line 203, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/", line 126, in gotoNext
  File "/usr/lib/anaconda/", line 602, in run
  File "/usr/bin/anaconda", line 956, in <module>
PVCreateError: pvcreate of pv "/dev/md1" failed

I see mdadm complaints on one of the vt's about the partitions (/dev/sda2, etc)
not existing.  fdisk shows empty tables for all of the disks.

I've also tried with RAID1 instead of RAID10 with the same result.

Comment 1 Orion Poplawski 2007-03-19 15:32:09 UTC
Created attachment 150379 [details]
anaconda dump

Comment 2 Orion Poplawski 2007-03-22 17:03:58 UTC
Still happens with  This strikes me as a pretty serious failure.  Can
anyone else reproduce?

Comment 3 Bill Peck 2007-03-26 20:25:39 UTC
I can confirm this.  I'm going to try a kickstart without lvm to see if its
specifically lvm causing the problem.

Comment 4 Michael DeHaan 2007-03-26 20:50:36 UTC
I've seen errors when just creating basic configs on a single IDE drive, no LVM
anywhere in the config, (1 GB swap, the rest being / and ext3) on T2 ... tried
dd'ing the drive before to clean it off, still no good.   I spoke briefly with
jeremy on #et-mgmt and he seemed to imply LVM was at fault.  This happens when
using kickstart or not.

To clarify, no lvm was involved, but the lvm still choked on my setup while
looking for partitions.  I don't exactly remember the details as I do not have
the machine around anymore but can help recreate if needed.

Comment 5 David Cantrell 2007-03-27 20:49:58 UTC
*** Bug 232502 has been marked as a duplicate of this bug. ***

Comment 6 Chris Lumens 2007-03-27 20:59:03 UTC
The problem here is that we're executing the clearpart code at least twice, and
one of those times is after we've committed the partitions to disk.  If you use
existing partitions or dd in your %pre script to clear out the disk label, you
should be able to work around this problem.  Of course, it's still a bug.

I'm not sure why this is only showing up as a bug now, and it's a bit of a
tangle of code to work through.  I have a preliminary patch worked up for
testing here.

Comment 7 Chris Lumens 2007-03-28 14:21:50 UTC
Committed a potential fix for this issue, though the risk of regressions when
editing this stuff is always pretty high.  I'll put it in MODIFIED for now. 
Please test the next build of anaconda and if this issue is solved, we'll close
it out.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.