Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232918 - /usr/sbin/redhat_lsb_trigger.i386 segfaults
Summary: /usr/sbin/redhat_lsb_trigger.i386 segfaults
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-lsb
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Lawrence Lim
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-19 14:38 UTC by Roy-Magne Mo
Modified: 2014-03-26 00:55 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-22 02:58:30 UTC


Attachments (Terms of Use)

Description Roy-Magne Mo 2007-03-19 14:38:48 UTC
Description of problem:
redhat_lsb_trigger.i386 during install of glibc-2.5.90-19

Version-Release number of selected component (if applicable):
redhat-lsb-3.1-13
glibc-2.5.90-19

How reproducible:
segfaults every time redhat_lsb_trigger.i386 is called

Steps to Reproduce:
1.
2.
3.
  
Actual results:
[root@localhost ~]# redhat_lsb_trigger.i386 
Segmentation fault


Expected results:


Additional info:

Comment 1 Kevin Fenzi 2007-03-30 20:22:50 UTC
Can you provide some info on the machine? This is a i386 install/machine?

Can you try: 

- Install the redhat-lsb-debuginfo package: 
rpm -ivh
http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/debug/redhat-lsb-debuginfo-3.1-13.i386.rpm
- Install 'gdb' if you don't have it already. 
- Run 'gdb redhat_lsb_trigger.i386' 
- When it fails do a 'bt' to list a backtrace. 

Attach that trace here. 

Comment 2 Roy-Magne Mo 2007-04-01 20:24:52 UTC
# rpm -qa redhat-lsb\*
redhat-lsb-3.1-13
redhat-lsb-debuginfo-3.1-13

i386 machine (PIII in this case)

# gdb redhat_lsb_trigger.i386
GNU gdb Red Hat Linux (6.6-8.fc7rh)
Copyright (C) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...
Using host libthread_db library "/lib/libthread_db.so.1".
(gdb) run
Starting program: /usr/sbin/redhat_lsb_trigger.i386
warning: shared library handler failed to enable breakpoint

Program received signal SIGSEGV, Segmentation fault.
main () at redhat_lsb_trigger.c:427
427     {
(gdb) bt
#0  main () at redhat_lsb_trigger.c:427
#1  0x08048235 in __libc_start_main (main=0x804823c <main>, argc=1,
    argv=0xbfe51954, init=0x8048214 <__libc_csu_init>,
    fini=0x8048219 <__libc_csu_fini>, rtld_fini=0, stack_end=0xbfe5194c)
    at redhat_lsb_trigger.c:496
#2  0x08048131 in _start ()
(gdb)


Comment 3 Lawrence Lim 2007-04-04 00:06:30 UTC
Thanks for the bug report.

Comment 4 Adam Huffman 2007-04-24 07:53:43 UTC
I've also been seeing this on an x86_64 machine.

Comment 6 Jakub Jelinek 2007-04-25 10:54:05 UTC
Make sure redhat_lsb_trigger.c is not compiled with -fstack-protector (which is
included in $RPM_OPT_FLAGS), the code in __libc_start_main doesn't set this up.

-gcc $RPM_OPT_FLAGS -Os -static -o redhat_lsb_trigger{.%{_target_cpu},.c}
-DLSBSOVER='"%{lsbsover}"' \
+gcc $RPM_OPT_FLAGS -fno-stack-protector -Os -static -o
redhat_lsb_trigger{.%{_target_cpu},.c} -DLSBSOVER='"%{lsbsover}"' \
  -DLDSO='"%{ldso}"' -DLSBLDSO='"/%{_lib}/%{lsbldso}"' -D_GNU_SOURCE

should do the trick.

Comment 7 A S Alam 2007-05-02 05:38:18 UTC
Test Result with latest build:
redhat-lsb-3.1-14.fc7
----
root@alamPunjabi i386]# redhat_lsb_trigger.i386
[root@alamPunjabi i386]#                    
---

Not more "Segmentation fault"

--
Tested on i386 machine

Comment 8 Dennis Jacobfeuerborn 2007-05-09 12:33:03 UTC
> Test Result with latest build:
> redhat-lsb-3.1-14.fc7

Where is this package available? It doesn't seem to be in rawhide.


Comment 9 Roy-Magne Mo 2007-05-22 02:58:30 UTC
Can't reproduce the segfault with redhat-lsb-3.1-14.fc7


Note You need to log in before you can comment on or make changes to this bug.