Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232896 - gdm create spurious audit entries
Summary: gdm create spurious audit entries
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gdm
Version: 5.0
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-19 11:21 UTC by Tomas Mraz
Modified: 2008-06-17 13:28 UTC (History)
0 users

Fixed In Version: RHBA-2008-0398
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-05-21 16:01:05 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0398 normal SHIPPED_LIVE gdm bug fix update 2008-05-19 23:09:06 UTC

Description Tomas Mraz 2007-03-19 11:21:53 UTC
+++ This bug was initially created as a clone of Bug #230401 +++

I cloned the RHEL4 bug report as it seems that this one somehow stayed unfixed 
in Fedora and RHEL5. There was an errata for RHEL4 with this.

+++ This bug was initially created as a clone of Bug #161230 +++

Description of problem:
Testing has shown that there is a spurious audit message being generated by gdm:

type=USER_ERR msg=audit(06/21/05 09:44:32.699:783952) : user pid=2155 uid=root 
auid=unknown(4294967295) msg='PAM bad_ident: user=? exe="/usr/bin/gdm-binary"
(hostname=?, addr=?, terminal=? result=User not known to the underlying
authentication module)'

This causes the audit system to log what could be interpretted as "suspicious"
events.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install audit package
2. reboot into run level 5
3. ausearch -i -x gdm
  

Actual Results:  Among other things you will find a USER_ERR message with no
PAM_USER.

Additional info:

-- Additional comment from tmraz@redhat.com on 2005-06-21 12:53 EST --
Created an attachment (id=115763)
Proposed patch

This patch simply disables the checking call to pam which is not necessary when
gdm is part of the distribution and not manually installed from sources by
user.

-- Additional comment from rstrode@redhat.com on 2007-03-06 14:17 EST --
This should be built into rawhide now.

Is there a RHEL5 bug somewhere too?

-- Additional comment from tmraz@redhat.com on 2007-03-19 07:19 EST --
Probably not. I'll clone this one.

Comment 1 RHEL Product and Program Management 2007-06-05 20:33:48 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Since this
bugzilla is in a component that is not approved for the current
release, it has been closed with resolution deferred.  You may
reopen this bugzilla for consideration in the next release.

Comment 2 RHEL Product and Program Management 2007-10-16 04:03:23 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 3 Ray Strode [halfline] 2008-01-14 16:39:49 UTC
devack

Comment 4 Ray Strode [halfline] 2008-01-14 17:00:21 UTC
should be fixed in gdm-2.16.0-35.el5

marking MODIFIED for QA

Comment 5 Ray Strode [halfline] 2008-01-14 17:00:53 UTC
hmm, i wonder how i managed to build this without a qa ack...

Comment 10 errata-xmlrpc 2008-05-21 16:01:05 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0398.html



Note You need to log in before you can comment on or make changes to this bug.