Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232887 - service xinetd status always returns success
Summary: service xinetd status always returns success
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xinetd
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jan Safranek
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-19 09:48 UTC by Tobias Oed
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: xinetd-2.3.14-9.fc6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-06-19 05:22:41 UTC


Attachments (Terms of Use)

Description Tobias Oed 2007-03-19 09:48:11 UTC
Description of problem:
I tried to use my standard
if service X status; then service X reload; else service X start; fi
with X=xinetd today and it failed because service xinetd status always returns
success even when xinied is stopped.

Version-Release number of selected component (if applicable):
xinetd-2.3.14-8

How reproducible:
100%

Steps to Reproduce:
1. service xinetd stop
2. service xined status
3. echo $?

Actual results:
0

Expected results:
Something else than 0

Additional info:
Quick patch to adress the issue
--- xinetd.orig 2006-10-01 22:33:47.000000000 +0200
+++ xinetd      2007-03-19 10:46:49.000000000 +0100
@@ -103,6 +103,7 @@
        ;;
     status)
        status $prog
+       RETVAL=$?
        ;;
     restart)
        restart

Comment 1 Fedora Update System 2007-05-21 22:26:48 UTC
xinetd-2.3.14-9.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.