Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232885 - HSDPA Performance with Sierra MC8755
Summary: HSDPA Performance with Sierra MC8755
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.0
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
: ---
Assignee: Ivan Vecera
QA Contact: Martin Jenner
URL:
Whiteboard:
Depends On:
Blocks: RHEL5u2_relnotes 420521 422431 422441
TreeView+ depends on / blocked
 
Reported: 2007-03-19 09:40 UTC by Hans-Gerd van Schelve
Modified: 2018-10-19 23:39 UTC (History)
7 users (show)

Fixed In Version: RHBA-2008-0314
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-05-21 14:42:00 UTC
Target Upstream Version:


Attachments (Terms of Use)
Update driver to 1.0.5 (deleted)
2007-05-16 17:17 UTC, Flavio Leitner
no flags Details | Diff
Patch to add device ID (deleted)
2007-05-16 17:18 UTC, Flavio Leitner
no flags Details | Diff
Test kernel with proposal applied patch (deleted)
2007-08-03 09:24 UTC, Ivan Vecera
no flags Details
Ivan's bigger backport after a review turnaround (deleted)
2007-09-19 01:14 UTC, Pete Zaitcev
no flags Details | Diff
Same as before, but with few more IDs removed (deleted)
2007-09-19 02:58 UTC, Pete Zaitcev
no flags Details | Diff
The proposed patch (deleted)
2007-11-06 16:11 UTC, Ivan Vecera
no flags Details | Diff
Final patch posted into kernel mailing list (deleted)
2007-12-06 15:12 UTC, Ivan Vecera
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0314 normal SHIPPED_LIVE Updated kernel packages for Red Hat Enterprise Linux 5.2 2008-05-20 18:43:34 UTC

Description Hans-Gerd van Schelve 2007-03-19 09:40:20 UTC
We have some ThinkPads T60 and X60 with internal MiniPCI UMTS / HSDPA Card. 
The Card is a Sierra MC8577 (USB Id 1199:6804). In RHEL5 there is a sierra
Kernel Module which supports this card in general but Lenovo has it's own
Product ID (6804). In Fedora 7 with Kernel vmlinuz-2.6.20-1.2986.fc7 there is a
newer Sierra Module that supports the card fine. Without the sierra Module we
can use the card with the usb-serial Kernel Module but only with about 40 KB/s
in Downlink. With the Sierra Module on Fedora 7 we get 140 - 150 KB/s!

Comment 3 Flavio Leitner 2007-05-16 17:17:08 UTC
Created attachment 154851 [details]
Update driver to 1.0.5

Comment 4 Flavio Leitner 2007-05-16 17:18:08 UTC
Created attachment 154852 [details]
Patch to add device ID

Patch based on upstream.

Comment 9 Ivan Vecera 2007-08-03 09:24:37 UTC
Created attachment 160592 [details]
Test kernel with proposal applied patch

Hello, I built and attached the test kernel package with applied patch to solve
the problem. Could you please test the package on target machine and report
here if the bug is solved?

-- Ivan

Comment 10 Issue Tracker 2007-08-03 10:53:18 UTC
Hans-Gerd, your comments are not automatically posted to BZ when entered in
IT.

I'll forward your message to BZ for you:

Ivan,

i tested your kernel on my x60. I get about 140 KB/s when downloading a
file, about 45 KB/s when uploading and ping round trip times from 140 ms.
The lsmod shows that the sierra module is loaded. So I think it's all
OK.

-- Hans-Gerd


This event sent from IssueTracker by navid 
 issue 118685

Comment 12 Pete Zaitcev 2007-09-19 00:40:27 UTC
See also bug 247884.

Comment 13 Pete Zaitcev 2007-09-19 01:14:15 UTC
Created attachment 198981 [details]
Ivan's bigger backport after a review turnaround

Ivan neglected to attach the patch which I acked, so doing it now. However,
now that I looked at option.c for bug 249660, I think we should be a bit more
proactive with the port. The original Kevin's driver had a few issues such
as the use of -EINPROGRESS, since fixed.

Comment 14 Pete Zaitcev 2007-09-19 02:58:56 UTC
Created attachment 199081 [details]
Same as before, but with few more IDs removed

On second thought, Ivan had a good idea. The current sierra wants to be too
modern with dynamic URBs and everything. It's a bridge too far.

Comment 15 Ivan Vecera 2007-09-19 10:02:51 UTC
> Ivan neglected to attach the patch which I acked, so doing it now. However,
> now that I looked at option.c for bug 249660, I think we should be a bit more
> proactive with the port. The original Kevin's driver had a few issues such
> as the use of -EINPROGRESS, since fixed.

Is it necessary to attach posted patch here? I'm a newbie in Red Hat.


Comment 16 Marco Bill-Peter 2007-10-31 19:30:37 UTC
*** Bug 247884 has been marked as a duplicate of this bug. ***

Comment 17 Ivan Vecera 2007-11-06 16:11:50 UTC
Created attachment 249401 [details]
The proposed patch

Hello, I would like to ask you to test again a test kernel package. We found
some issue that had to be solved. So we need to know if the current solution
works well. Could you please test this kernel package and report a feedback?
You can find it on:
http://people.redhat.com/ivecera/bz232885/

Thanks a lot.

-- Ivan

Comment 19 Navid Sheikhol-Eslami 2007-12-06 09:39:20 UTC
Ivan, the customer now requires the device to work on T61 so I had to add the
correct USB IDs to the patch for USB_DEVICE(0x1199, 0x6813).

With this tiny modification to your patch, the customer's feedback was positive.

Thank you.

-- Navid

Comment 20 Ivan Vecera 2007-12-06 10:59:36 UTC
Thank you Navid, I will send a corrected patch into mailing-list.

Comment 21 Ivan Vecera 2007-12-06 15:12:14 UTC
Created attachment 279781 [details]
Final patch posted into kernel mailing list

Comment 22 Jay Turner 2007-12-13 14:24:19 UTC
Do we have access to hardware for testing?

Comment 23 Navid Sheikhol-Eslami 2007-12-13 14:49:00 UTC
Jay, I have a T61 here in EMEA available for testing.

-- Navid

Comment 24 Jay Turner 2007-12-13 15:21:36 UTC
QE ack for RHEL5.2 then.

Comment 26 Don Zickus 2008-01-24 16:08:40 UTC
in 2.6.18-74.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5

Comment 28 Don Domingo 2008-02-07 02:21:53 UTC
this bug has been tagged for inclusion in the RHEL5.2 release notes. please post
the necessary content for it. thanks!

Comment 29 Don Domingo 2008-04-02 02:14:02 UTC
Hi,
the RHEL5.2 release notes will be dropped to translation on April 15, 2008, at
which point no further additions or revisions will be entertained.

a mockup of the RHEL5.2 release notes can be viewed at the following link:
http://intranet.corp.redhat.com/ic/intranet/RHEL5u2relnotesmockup.html

please use the aforementioned link to verify if your bugzilla is already in the
release notes (if it needs to be). each item in the release notes contains a
link to its original bug; as such, you can search through the release notes by
bug number.

Cheers,
Don

Comment 31 Don Domingo 2008-04-10 23:28:36 UTC
Thanks Ivan. release note add to "Driver Updates => Network".

Please advise (before April 15) if any further revisions are required. thanks!

Comment 33 errata-xmlrpc 2008-05-21 14:42:00 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0314.html



Note You need to log in before you can comment on or make changes to this bug.