Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232884 - getfacl exit code is reversed
Summary: getfacl exit code is reversed
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: acl
Version: rawhide
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact:
URL:
Whiteboard:
: 230579 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-19 09:06 UTC by Jim Meyering
Modified: 2013-03-13 20:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-21 10:40:32 UTC


Attachments (Terms of Use)
apply this patch on top of acl-2.2.39-walk.patch (deleted)
2007-03-19 09:06 UTC, Jim Meyering
no flags Details | Diff

Description Jim Meyering 2007-03-19 09:06:56 UTC
Description of problem:
  getfacl exits 0 upon failure, and nonzero when it succeeds

Version-Release number of selected component (if applicable):
  $ getfacl --version                       
  getfacl 2.2.39                                                               
       
  $ rpm -qf /usr/bin/getfacl
  acl-2.2.39-3.fc7                                                                 

How reproducible:
  always

Steps to Reproduce:
  $ touch k; getfacl k >&/dev/null || echo bug
  bug
  $ getfacl /no-file >&/dev/null && echo bug
  bug
  
Actual results:
  see above

Expected results:
  no output from those two commands

Additional info:
  patch attached

Comment 1 Jim Meyering 2007-03-19 09:06:57 UTC
Created attachment 150354 [details]
apply this patch on top of acl-2.2.39-walk.patch

Comment 2 Thomas Woerner 2007-03-21 10:40:32 UTC
Fixed in rawhide in package acl-2.2.39-3.1.

Comment 3 Jiri Moskovcak 2007-07-11 09:54:12 UTC
*** Bug 230579 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.