Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232882 - yum-updatesd claims there are updates available although there aren't
Summary: yum-updatesd claims there are updates available although there aren't
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: James Antill
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-19 08:11 UTC by David Juran
Modified: 2014-01-21 22:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-08-03 19:45:26 UTC


Attachments (Terms of Use)

Description David Juran 2007-03-19 08:11:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.10) Gecko/20070313 Fedora/1.5.0.10-5.fc6 Firefox/1.5.0.10

Description of problem:
I've noticed that occasionally yum-updatesd claims there are updates available but when running 'yum upgrade' I'm told there's no updates available. I realise this is a bit thin but is there some way of increasing the verbosity of yum-updatesd so that it can provide a bit more information about this package it claims to have found? 

Monitoring the system dbus, I see the following message:

signal sender=:1.129 -> dest=(null destination) path=/UpdatesAvail; interface=edu.duke.linux.yum; member=UpdatesAvailableSignal
   string "3"

But then running yum yields:

[djuran@a88-115-207-64 iso]$ sudo yum upgrade
Password:
Loading "priorities" plugin
Loading "installonlyn" plugin
Loading "fastestmirror" plugin
Loading "changelog" plugin
Setting up Upgrade Process
Setting up repositories
Loading mirror speeds from cached hostfile
Reading repository metadata in from local files
Reducing Fedora Extras - Development Tree to included packages only
Finished
73 packages excluded due to repository priority protections
No Packages marked for Update/Obsoletion


Version-Release number of selected component (if applicable):
yum-3.0.3-1.fc6

How reproducible:
Sometimes


Steps to Reproduce:
1. Note that pupplet claims there are updates available
2. 'yum upgrade' claims everything is up to date
3.

Actual Results:


Expected Results:


Additional info:

Comment 1 Jeremy Katz 2007-03-19 22:16:23 UTC
You can run yum-updatesd with -f to get it to run in the foreground and then it
will print out some more bits

Comment 2 David Juran 2007-03-20 09:50:08 UTC
After starting the yum-updatesd in the foreground, it stopped reporting updates
being available. I then restarted it as a daemon and still it (correctly) didn't
report any updates being available. Does this make any kind of sense to anyone? 



Comment 3 Seth Vidal 2007-08-03 19:45:26 UTC
yes, if you assume it is broken :)

If you can - try yum-updatesd from rawhide and reopen if this bug doesn't go away.


Note You need to log in before you can comment on or make changes to this bug.