Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232875 - scim-tables Chang-Jie preedit was not cleared after focus out then focus in.
Summary: scim-tables Chang-Jie preedit was not cleared after focus out then focus in.
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: scim-tables
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caius Chance
QA Contact:
URL:
Whiteboard:
Depends On: 217639
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-19 06:21 UTC by Caius Chance
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-19 06:38:43 UTC


Attachments (Terms of Use)

Description Caius Chance 2007-03-19 06:21:25 UTC
+++ This bug was initially created as a clone of Bug #217639 +++

Description of problem:
The preedit still exists even user focus out and focus in SCIM.

Version-Release number of selected component (if applicable):
scim-tables-chinese-0.5.6-7
scim-tables-0.5.6-7

How reproducible:
Always

Steps to Reproduce:
1. Ensure scim, scim-tables, scim-tables-chinese have been installed.
2. Ensure scim is started by default: at gnome desktop, use im-chooser on system
preference menu.
3. Ensure Chang Jie (5) was selected in SCIM: right click SCIM icon on taskbar
and select config item, go to IME selection tab and tick Chinese -> Chang Jie 5.
4. Start gedit: at gnome desktop, press alt-F2, input gedit and press enter.
5. Press ctrl space to turn on SCIM, click IME name on tool bar and change to
Chang Jie 5.
6. Input 'a' key, it will becomes 日 on preedit and candidate list is shown.
7. Press ctrl space twice, the preedit buffer is still there.
  
Actual results:
Preedit buffer is not cleared.

Expected results:
Preedit buffer is cleared.

Additional info:
Not sure whether Changjie 3 and Changjie have same problem or not.

-- Additional comment from petersen@redhat.com on 2006-11-28 23:10 EST --
Also happens with scim-pinyin apparently.

-- Additional comment from petersen@redhat.com on 2006-11-28 23:20 EST --
I guess this is related to scim-bridge since the sense that
we have gtkimm-clear-preedit-on-reset-174143.patch in our scim package.

Should we modify scim-bridge to do the same?

As it stands this coincides with upstream's preedit behaviour.


-- Additional comment from petersen@redhat.com on 2006-11-29 01:26 EST --
See bug 174143 for the scim case.

-- Additional comment from cchance@redhat.com on 2006-11-29 01:51 EST --
FYI, Chewing's behavior has been changed to "clearing" by me, after upstream's
approval.

IMHO, as Chang Jie is currently not be used with long preedit during inputting
(i.e. the frequency that users commit characters in preedit is relatively high),
it doen't not very make sense to keep preedit after focus out and in.

-- Additional comment from phuang@redhat.com on 2006-11-29 02:12 EST --
IMO, keeping preedit string after focus out is complex, maybe it will make users
puzzled.
I think commiting preedit string or clearing it are more appropriate. 

-- Additional comment from cchance@redhat.com on 2007-03-19 02:12 EST --
Created an attachment (id=150350)
Patch


-- Additional comment from cchance@redhat.com on 2007-03-19 02:19 EST --
Built & sent patch to upstream.

This is good to push to FC6.

Comment 1 Caius Chance 2007-03-19 06:32:24 UTC
Patched, tested, built.

Pending to carry out FUP.

Comment 2 Caius Chance 2007-03-19 06:38:43 UTC
FUP submitted.

Comment 3 Fedora Update System 2007-03-19 23:01:25 UTC
scim-tables-0.5.7-2.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.