Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232870 - net-snmp RHEL5-server i386 HOST-RESOURCES-MIB :: hrSWInstalled returns nothing
Summary: net-snmp RHEL5-server i386 HOST-RESOURCES-MIB :: hrSWInstalled returns nothing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: net-snmp
Version: 5.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jan Safranek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-19 05:45 UTC by John Willis
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version: RHBA-2007-0498
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-07 17:16:12 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0498 normal SHIPPED_LIVE net-snmp bug fix update 2007-10-30 14:42:44 UTC

Description John Willis 2007-03-19 05:45:24 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; InfoPath.1; .NET CLR 2.0.50727)

Description of problem:

When I use the following command on RHEL4u0 through RHEL4u4 I get the expected listing of installed software information.

snmpwalk -v1 -c public localhost HOST-RESOURCES-MIB::hrSWInstalled

When I use the same command on RHEL5-server it simply returns a prompt with no listing.

Performing the same query on other Mibs in the same host group returns information on [ hrMemorySize, hrSWRunTable, hrSWRunPerfTable ]

Other than returning no data it seems to behave as expected, the daemon does not crash, its like hr_swinst.c was not compiled into the daemon.

Here are the modifications to /etc/snmpd/snmpd.conf used to grant access:

#       sec.name       source        community
com2sec testUser  default       public

#       groupName        securityModel   securityName
group   testGroup        v1              testUser
group   testGroup        v2c             testUser

#
view    all             included    .1      80
access  testGroup  ""          any     noauth exact   all  none  none


Version-Release number of selected component (if applicable):
net-snmp-5.3.1-14.el5.i386.rpm

How reproducible:
Always


Steps to Reproduce:
1. Install RHEL5-server
2. Edit /etc/snmp/snmpd.conf to grant access
3. Bounce daemon, /etc/init.d/stop, /etc/init.d/start
4. Run [ snmpwalk -v1 -c public localhost HOST-RESOURCES-MIB::hrSWInstalled ] as root

Actual Results:
As the root user it returned the prompt
#


Expected Results:
A long listing of rpm package indexes, package names, and package install dates and times.

Additional info:
RHEL5-server

 715945 Jan 23 14:26 net-snmp-5.3.1-14.el5.i386.rpm
1801986 Jan 23 14:26 net-snmp-devel-5.3.1-14.el5.i386.rpm
1187340 Jan 23 14:26 net-snmp-libs-5.3.1-14.el5.i386.rpm
 196673 Jan 23 14:26 net-snmp-perl-5.3.1-14.el5.i386.rpm
 182737 Jan 23 14:26 net-snmp-utils-5.3.1-14.el5.i386.rpm

I tried rebuilding the packages from SRC rpms as well on a developer install of RHEL5-server, to the same effect. I had no trouble compiling (after installing the required devel dependecy packages).

The net-snmp community seems to have had some issues accomodating rpm on IRIX, Solaris, SuSE recently. There are some comments in the source code that rpm is difficult to work with, and there is a test which seems to determine whether or not rpm support will be enabled as part of the hr_swinst.c source code.

I checked the procedure against RHEL4u0 i386, RHEL4u1 i386, RHEL4u2 i386, RHEL4u3 i386, RHEL4u4 i386 and the command:

snmpwalk -v1 -c public localhost HOST-RESOURCES-MIB::hrSWInstalled 

always returned good data.

Comment 2 RHEL Product and Program Management 2007-05-17 09:04:37 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 7 errata-xmlrpc 2007-11-07 17:16:12 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0498.html



Note You need to log in before you can comment on or make changes to this bug.