Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232860 - scim-tables: Missing custom phrase removal function for candidate auto select IMEs.
Summary: scim-tables: Missing custom phrase removal function for candidate auto select...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: scim-tables
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caius Chance
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-19 01:40 UTC by Caius Chance
Modified: 2008-03-11 06:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-03-11 06:54:42 UTC


Attachments (Terms of Use)
patch (deleted)
2008-03-11 06:27 UTC, Caius Chance
no flags Details | Diff
spec patch (deleted)
2008-03-11 06:27 UTC, Caius Chance
no flags Details | Diff

Description Caius Chance 2007-03-19 01:40:57 UTC
Description of problem:
Some 'direct outputting' IMEs in scim-tables needs helper for user phrase
management.

Version-Release number of selected component (if applicable):
scim-tables-0.5.6-7

How reproducible:
Always.

Steps to Reproduce:
1. Ensure Wubi is availble for inputting.
2. Start gedit from gnome-terminal on GUI desktop.
3. Create user phrase by odd key combinations:
   - Type a phrase. (e.g. 't' 'i' 'e' 'space' 'f' 'q' 'p' 'space')
   - Add a user phrase. ('ctrl+a' 't' 'i' 'f' 'q' 'enter')
4. Type user phrase and try to delete such user phrase.
   ('t' 'i' 'f' 'q'...)
  
Actual results:
User pharase directly outputted. There is no candidate window for user to
highlight on such phrase and press 'ctrl-d' to delete that.

Expected results:
User could delete such user string in candidate window by highlight and 'ctrl-d'
to remove.

Additional info:
Changjie is also in scim-tables and has no problem for such process because it
is not a 'direct outputting' IME. It needs 'space' to output in all situation.

Check bug #223587 for related problem discovered.

Comment 1 Caius Chance 2007-03-19 01:45:19 UTC
(This bug should be treated as bug clone of bug #223587, after bug #223587 had
 been redefined as request of 'Develop scim-tables helper for user phrase
management.')

Comment 2 Caius Chance 2008-03-11 06:26:35 UTC
Custom phrase removal was not working because candidates "auto select" function
on certain IMEs. Non-shown lookup window results SCIM unable to delete custom
phrase.

Patch makes removal possible both with or without lookup window.

Comment 3 Caius Chance 2008-03-11 06:27:37 UTC
Created attachment 297566 [details]
patch

Comment 4 Caius Chance 2008-03-11 06:27:56 UTC
Created attachment 297567 [details]
spec patch

Comment 5 Caius Chance 2008-03-11 06:54:42 UTC
Built in rawhide.


Note You need to log in before you can comment on or make changes to this bug.