Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232856 - simplify_gen_subreg gets internal compiler error
Summary: simplify_gen_subreg gets internal compiler error
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc34
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-18 23:55 UTC by Paul McQuesten
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-19 08:29:03 UTC


Attachments (Terms of Use)
Preprocessed source stored into /tmp/ccTnUUOo.out file, please attach this to your bugreport. (deleted)
2007-03-18 23:55 UTC, Paul McQuesten
no flags Details

Description Paul McQuesten 2007-03-18 23:55:32 UTC
Description of problem:

g++ -g -DDEBUG  -c apFact.cpp
apFact.cpp: In member function `const Signature& Glossary::gang(Cite) const':
apFact.cpp:350: warning: returning reference to temporary
apFact.cpp:350: internal compiler error: in simplify_gen_subreg, at
simplify-rtx.c:3533

Version-Release number of selected component (if applicable):
Reading specs from /usr/lib/gcc/i386-redhat-linux/3.4.4/specs
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man
--infodir=/usr/share/info --enable-shared --enable-threads=posix
--disable-checking --with-system-zlib --enable-__cxa_atexit
--disable-libunwind-exceptions --enable-java-awt=gtk --host=i386-redhat-linux
Thread model: posix
gcc version 3.4.4 20050721 (Red Hat 3.4.4-2)


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
compiler barfs

Expected results:
generate good code

Additional info:

Comment 1 Paul McQuesten 2007-03-18 23:55:32 UTC
Created attachment 150343 [details]
Preprocessed source stored into /tmp/ccTnUUOo.out file, please attach this to your bugreport.

Comment 2 Jakub Jelinek 2007-03-19 08:29:03 UTC
FC3 is not supported anymore (for more than a year).
FC6 gcc correctly reports error in the Glossary::gang function instead.
return assoc ? *assoc : &emptySign;
should have been:
return assoc ? *assoc : emptySign;
because &emptySign has type const Signature * rather than const Signature &.


Note You need to log in before you can comment on or make changes to this bug.