Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232851 - Python2.5 error when updating software
Summary: Python2.5 error when updating software
Keywords:
Status: CLOSED DUPLICATE of bug 230877
Alias: None
Product: Fedora
Classification: Fedora
Component: python
Version: rawhide
Hardware: powerpc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Andrew
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-18 22:28 UTC by Andrew
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-20 03:12:07 UTC


Attachments (Terms of Use)
plain text document (deleted)
2007-03-18 22:28 UTC, Andrew
no flags Details
yum repository file (deleted)
2007-03-20 02:01 UTC, Andrew
no flags Details
yum repository file (deleted)
2007-03-20 02:02 UTC, Andrew
no flags Details
yum repository file (deleted)
2007-03-20 02:03 UTC, Andrew
no flags Details

Description Andrew 2007-03-18 22:28:51 UTC
Description of problem:
Error when updating software with GUI software manager

Version-Release number of selected component (if applicable):
Python 2.5

How reproducible:


Steps to Reproduce:
1. Click Applications
2. Click Add/Remove Software
3. 
  
Actual results:
Component: Software Manager
Summary: TBcf9087aa __init__.py:478:_getGroups:GroupsError: No Groups Available
in any repository

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/pirut/GroupSelector.py", line 311, in
_categorySelected
    self._populateGroups(cat.groups, fbpix)
  File "/usr/lib/python2.5/site-packages/pirut/GroupSelector.py", line 315, in
_populateGroups
    filter(lambda x: self.ayum.comps.has_group(x), groups))
  File "/usr/lib/python2.5/site-packages/pirut/GroupSelector.py", line 315, in
<lambda>
    filter(lambda x: self.ayum.comps.has_group(x), groups))
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 505, in <lambda>
    comps = property(fget=lambda self: self._getGroups(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 478, in _getGroups
    raise Errors.GroupsError, 'No Groups Available in any repository'
GroupsError: No Groups Available in any repository

Local variables in innermost frame:
repo: development
self: <__main__.PackageManager object at 0x10537ff0>
reposWithGroups: [<yum.yumRepo.YumRepository object at 0x10592b90>,
<yum.yumRepo.YumRepository object at 0x10592d70>]
overwrite: False

Expected results:


Additional info:

Comment 1 Andrew 2007-03-18 22:28:51 UTC
Created attachment 150341 [details]
plain text document

Comment 2 Jeremy Katz 2007-03-19 20:24:02 UTC
What repositories are you pointing at?  Does this still occur?  As it looks like
a case where there aren't any comps files configured with your repository.

Comment 3 Andrew 2007-03-20 01:48:58 UTC
I have several .repo files in my /etc/yum.repos.d directory. Would you like me
to attach them or copy & paste the repositories?

Comment 4 Andrew 2007-03-20 02:01:12 UTC
Created attachment 150455 [details]
yum repository file

Comment 5 Andrew 2007-03-20 02:02:20 UTC
Created attachment 150456 [details]
yum repository file

Comment 6 Andrew 2007-03-20 02:03:32 UTC
Created attachment 150457 [details]
yum repository file

Comment 7 Andrew 2007-03-20 02:11:39 UTC
I have attached:
1) fedora-core.repo
2) fedora-development.repo
3) fedora-updates.repo

Other files in the /etc/yum.repos.d directory...
fedora-extras-development.repo
fedora-extras.repo
fedora-legacy.repo
fedora-updates-testing.repo

Comment 8 Andrew 2007-03-20 02:18:09 UTC
This error has occured every time I use the Software Manager. It usually happens
right after installing/removing software and clicking on "Base" within the
"Browse" tab.

Comment 9 Jeremy Katz 2007-03-20 03:12:07 UTC

*** This bug has been marked as a duplicate of 230877 ***


Note You need to log in before you can comment on or make changes to this bug.