Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232846 - Network hangs with "sky2 eth1: phy write timeout" on Marvell 88E8056
Summary: Network hangs with "sky2 eth1: phy write timeout" on Marvell 88E8056
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-18 20:30 UTC by Stewart Adam
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-08-29 23:02:27 UTC


Attachments (Terms of Use)

Description Stewart Adam 2007-03-18 20:30:19 UTC
Description of problem:
About once every 20 boots network will not work and refuse to initialize too. I
always get log messages about sky2 and "phy write timout" when this happens. I
am using the built-in gigabit LAN controller on the GA-965P-S3, the Marvel
88E8056 (lspci output in additional info)

Version-Release number of selected component (if applicable):
kernel-2.6.20-1.2997.fc7

How reproducible:
Sometimes

Steps to Reproduce:
1. Reboot
2. Try to use the internet
3. Repeat
  
Actual results:
Eventually eth1 will not be initialized on boot and internet will not work. The
messages included below are found in the logs

Expected results:
No sky2 timeout problems

Additional info:
Relevant messages in /var/log/messages:

PM: Adding info for No Bus:eth0
sky2 eth0: addr 00:16:e6:8c:11:ee
sky2 eth1: enabling interface
sky2 eth1: phy write timeout
sky2 eth1: phy write timeout
sky2 eth1: phy write timeout
sky2 eth1: phy write timeout
sky2 eth1: phy write timeout
sky2 eth1: phy write timeout
sky2 eth1: phy write timeout
sky2 eth1: phy write timeout
sky2 eth1: phy write timeout
sky2 eth1: phy write timeout
sky2 eth1: ram buffer 1020K
ADDRCONF(NETDEV_UP): eth1: link is not ready

hardware:
04:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8056 PCI-E Gigabit
Ethernet Controller (rev 14)

Comment 1 Stewart Adam 2007-03-27 20:46:32 UTC
The amount of time this has been happening lately has almost tripled... I'm not
sure if it's coincidence, but it seems to have started happening more often with
the 2.6.20-3xxx kernels.

Comment 2 Dave Jones 2007-04-05 19:52:57 UTC
I reported this to the upstream driver maintainer.  He managed to track down teh
same board, and can reproduce it, though it may not be a simple fix as we don't
have documentation for this variant of the chip.


Comment 3 Stewart Adam 2007-04-05 20:43:00 UTC
Alright... For now, certain kernels seem to be stabler than others - I haven't
had it occur with 3038 yet for example...

If I can help in any way with backtracks, etc, let me know.

Comment 4 Frédéric COIFFIER 2007-06-21 07:44:24 UTC
I have the problem with a 2.6.20-1.2952.fc6
Two days ago, the network was cut (no ping) but the system continued to work. I
needed to restart the server.
Today, after these messages :

Jun 21 05:19:14 NXLX02 kernel: NETDEV WATCHDOG: eth0: transmit timed out
Jun 21 05:19:14 NXLX02 kernel: sky2 eth0: tx timeout
Jun 21 05:19:14 NXLX02 kernel: sky2 eth0: transmit ring 94 .. 71 report=94 done=94
Jun 21 05:19:14 NXLX02 kernel: sky2 gmac control 0x1800 status 0xd000
Jun 21 05:19:14 NXLX02 kernel: sky2 eth0: disabling interface
Jun 21 05:19:14 NXLX02 kernel: sky2 eth0: enabling interface
Jun 21 05:19:14 NXLX02 kernel: sky2 eth0: ram buffer 48K
Jun 21 05:19:16 NXLX02 kernel: sky2 eth0: Link is up at 100 Mbps, full duplex,
flow control both

The network was very, very slow to respond with a very small bandwidth.
After this operation :

$ rmmod sky2
$ modprobe sk2

The network connection was restored

Is there a correction for this problem ?

Comment 5 Stewart Adam 2007-08-29 23:02:27 UTC
I've been having no problems ever since the sky2 fixes in the F8 kernels (eg,
"sky2: re-enable lost interrupt workarounds"). I'll reopen if the issue pops up
again.


Note You need to log in before you can comment on or make changes to this bug.