Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232840 - lyx: can't handle its templates
Summary: lyx: can't handle its templates
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: lyx
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-18 18:18 UTC by Penelope Fudd
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-21 13:24:52 UTC


Attachments (Terms of Use)

Description Penelope Fudd 2007-03-18 18:18:26 UTC
Description of problem:
Try opening up a new document from each of the templates, and you'll find that
not many work, either with an error "The document uses a missing TeX class
"xxx", LyX will not be able to produce output" on loading, or an error "Package
babel Error: You haven't defined the language ENGLISH yet."

Version-Release number of selected component (if applicable):
lyx-1.4.4-2.fc6

How reproducible:
Always

Steps to Reproduce:
1.Start lyx
2.Select 'File/New from template'
3.Try them all
  
Actual results:
Errors

Expected results:
No errors

Additional info:
This may be upstream, but it needs to be fixed.

Comment 1 Penelope Fudd 2007-03-18 18:50:13 UTC
The babel error occurs when you try 'view/DVI' or view/anything from the menu.

Comment 2 Penelope Fudd 2007-03-18 18:56:31 UTC
That's with the IEEEtran.lyx template, for example.

Comment 3 Rex Dieter 2007-03-19 13:02:05 UTC
Right, these are templates for given latex classes, which as you found out, are
not all installed (or even available) by default in Fedora.

For the record, many of the templates *do* work :) including: 
beamer-*
docbook-*
hollywood
letter
slides

Are you suggesting we remove the templates that don't work out of the box?



Comment 4 Penelope Fudd 2007-03-20 00:30:20 UTC
I was hoping to use lyx to help write my scientific report so I could hand in a
professional looking piece of work today, but the appropriate templates aren't
working, and attempting to write a paper from scratch with an unfamiliar program
is no picnic.  I temporarily gave up and used openoffice.

If the templates that don't work out of the box are removed, a new user will
have a more positive experience (everything works), but will think that lyx is a
useless toy (few templates), when in fact it's pretty powerful.

A better solution is to figure out what other latex classes have to be installed
to make everything in lyx work, package them up either separately or as part of
the normal lyx package, and have lyx depend on them.

I am a LyX and LaTeX newbie, and I don't know squat about TeX.  I came across
LyX just last week, and thought it was the greatest thing since sliced bread. 
But then I tried to use it, and the bugs (well, misconfigurations, or maybe
unpackaged files) just kept getting in my way.

I don't want to be harsh, but the linux world doesn't need any more half-working
packages; we're here to beat Microsoft, not just equal them.

Comment 5 Rex Dieter 2007-03-21 13:18:06 UTC
Thanks for your constructive criticism, well said.

> A better solution is to figure out what other latex classes have to be 
>installed to make everything in lyx work

In your particular case, tetex-IEEEtran is available, so
$ yum install tetex-IEEEtran
and running lyx menu: Tools->Reconfigure does the trick.  

I'll double check availability for all the other template classes as well, and
add them as package requirements.  

Unfortunately, some classes aren't available in Fedora (yet).  When/if they do
become available, I'll add them as Required dependencies for lyx.

Comment 6 Rex Dieter 2007-03-21 13:24:52 UTC
%changelog
* Wed Mar 21 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.4.4-3
- +Requires: tetex-IEEEtran (#232840)



Note You need to log in before you can comment on or make changes to this bug.